summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/librcutil/Makefile.am')
-rw-r--r--src/core/librcutil/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/core/librcutil/Makefile.am b/src/core/librcutil/Makefile.am
new file mode 100644
index 0000000..086764b
--- /dev/null
+++ b/src/core/librcutil/Makefile.am
@@ -0,0 +1,19 @@
+AUTOMAKE_OPTIONS = foreign
+
+INCLUDES = \
+ -I$(top_srcdir)/include \
+ $(RCSCRIPTS_DEFINES)
+
+lib_LTLIBRARIES = librcutil.la
+
+librcutil_la_LDFLAGS = \
+ -Wl,--version-script,$(srcdir)/librcutil.map
+librcutil_la_SOURCES = \
+ debug.c \
+ string.c \
+ file.c \
+ config.c \
+ dynbuf.c \
+ simple-regex.c
+
+EXTRA_DIST = librcutil.map