summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp/nzbperl/nzbperl-0.6.8.ebuild')
-rw-r--r--net-nntp/nzbperl/nzbperl-0.6.8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-nntp/nzbperl/nzbperl-0.6.8.ebuild b/net-nntp/nzbperl/nzbperl-0.6.8.ebuild
new file mode 100644
index 000000000..55e062b47
--- /dev/null
+++ b/net-nntp/nzbperl/nzbperl-0.6.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="nzb based nntp/usenet downloader in perl"
+HOMEPAGE="http://noisybox.net/computers/nzbperl"
+SRC_URI="${HOMEPAGE}/${P}.pl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 ssl"
+
+DEPEND="dev-lang/perl
+ app-text/uudeview
+ perl-core/Time-HiRes
+ perl-core/Getopt-Long
+ dev-perl/TermReadKey
+ dev-perl/Term-ANSIColor
+ dev-perl/XML-DOM
+ ssl? ( dev-perl/IO-Socket-SSL )
+ ipv6? ( dev-perl/IO-Socket-INET6 )
+"
+
+src_install() {
+ newbin ${DISTDIR}/${P}.pl ${PN}
+ dodoc ${FILESDIR}/${PN}rc.sample
+}
+
+pkg_postinst() {
+ if ! built_with_use dev-lang/perl ithreads; then
+ ewarn "WARNING: dev-lang/perl was built with ithreads disabled, please start nzbperl"
+ ewarn "with --dthreadct 0 to use single-threaded nzbperl OR remerge dev-lang/perl"
+ ewarn "with ithreads in your USE flags."
+ ewarn ""
+ ewarn "Note that using --dthreadct 0 will cause downloads to pause during decoding,"
+ ewarn "so it is recommended that you build perl with ithreads enabled."
+ fi
+
+ einfo "A sample config file has been copied into /usr/share/doc/${PF}"
+ einfo "You may want to take it as a sample for your ~/.nzbperlrc"
+}