summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Whitlock (whitslack) <matt@whitlock.name>2010-05-22 12:22:17 +0000
committerMatt Whitlock (whitslack) <matt@whitlock.name>2010-05-22 12:22:17 +0000
commitfd49110a0d4f0413c2dea168085564f392c59144 (patch)
tree0256509443d2360e1e51b695bafddd784ca2cc9f /media-libs
parentAutomatic update to use.local.desc (diff)
downloadsunrise-fd49110a0d4f0413c2dea168085564f392c59144.tar.gz
sunrise-fd49110a0d4f0413c2dea168085564f392c59144.tar.bz2
sunrise-fd49110a0d4f0413c2dea168085564f392c59144.zip
new version: media-libs/unicap-0.9.8 (bug 175881)
Note: Upstream split the unicap library into three parts: media-libs/unicap, media-libs/unicapgtk, and media-libs/ucil. svn path=/sunrise/; revision=10592
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/ucil/ChangeLog11
-rw-r--r--media-libs/ucil/Manifest5
-rw-r--r--media-libs/ucil/files/libpng14.patch39
-rw-r--r--media-libs/ucil/metadata.xml7
-rw-r--r--media-libs/ucil/ucil-0.9.8.ebuild51
-rw-r--r--media-libs/unicap/ChangeLog9
-rw-r--r--media-libs/unicap/Manifest8
-rw-r--r--media-libs/unicap/metadata.xml3
-rw-r--r--media-libs/unicap/unicap-0.9.7.ebuild60
-rw-r--r--media-libs/unicap/unicap-0.9.8.ebuild50
-rw-r--r--media-libs/unicapgtk/ChangeLog11
-rw-r--r--media-libs/unicapgtk/Manifest4
-rw-r--r--media-libs/unicapgtk/metadata.xml6
-rw-r--r--media-libs/unicapgtk/unicapgtk-0.9.8.ebuild35
14 files changed, 234 insertions, 65 deletions
diff --git a/media-libs/ucil/ChangeLog b/media-libs/ucil/ChangeLog
new file mode 100644
index 000000000..d98c82b60
--- /dev/null
+++ b/media-libs/ucil/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-libs/ucil
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 22 May 2010; Matt Whitlock (whitslack) <matt@whitlock.name>
+ +files/libpng14.patch, +ucil-0.9.8.ebuild, +metadata.xml:
+ new ebuild: media-libs/ucil-0.9.8 (bug 175881)
+
+ Note: Upstream split the unicap library into three parts. This is one of
+ them, along with media-libs/unicap and media-libs/unicapgtk.
+
diff --git a/media-libs/ucil/Manifest b/media-libs/ucil/Manifest
new file mode 100644
index 000000000..f3f3fff9c
--- /dev/null
+++ b/media-libs/ucil/Manifest
@@ -0,0 +1,5 @@
+AUX libpng14.patch 1382 RMD160 d5b3e435a3c98060a85c2fe9d6f6568044a7bd9b SHA1 370d3dbc4c6473627e87222523a3b6549f02b0d9 SHA256 b15de9ac7affae133cc68482145ca3fc383cc58b7e8abc5232d95215ccd091a9
+DIST libucil-0.9.8.tar.gz 450809 RMD160 03c416388f302c1d260fc77edaa6d00e8ef177d3 SHA1 1a03ba08e511a379e59ff38350f6075a87daf30c SHA256 1d3b73bb7a88084b4eea92f2e1c57b36159a66aef68098e9cbe19f98910d1018
+EBUILD ucil-0.9.8.ebuild 1297 RMD160 772380f29cffa41e22dc3972d19c085d2fb8a11d SHA1 ed28038b06a98debe0aa3bbecfa3a3e67cc730d1 SHA256 7c3422b6e11f8614b66dd9c6fff482ebd3231d9e63ca7b882de851b4d93616e7
+MISC ChangeLog 429 RMD160 f61ec13b9f9f4db474bb6893f9d3e164c36a4bca SHA1 5a5640f26bc210f59bd5daf4cdad04204efced64 SHA256 d1172e0f6e9f294dd8a3d2c4640315caabbefd0a79fc04637f9e1826126bd89a
+MISC metadata.xml 311 RMD160 7989e7cefb05e8a9f6ce2b2fa0b05852cb2e0710 SHA1 dd5e1fdb5dc6bee8e512708e3788d01517704920 SHA256 5f8984e3b104ed749c04c6dc3c4d32c9f4ba2fb6a6eb3b4d8fb9858a521430c8
diff --git a/media-libs/ucil/files/libpng14.patch b/media-libs/ucil/files/libpng14.patch
new file mode 100644
index 000000000..c579c9dcf
--- /dev/null
+++ b/media-libs/ucil/files/libpng14.patch
@@ -0,0 +1,39 @@
+diff -Naur src.old/ucil_png.c src/ucil_png.c
+--- src.old/ucil_png.c 2010-01-17 07:49:29.000000000 +0000
++++ src/ucil_png.c 2010-05-22 10:35:55.090733124 +0000
+@@ -77,7 +77,7 @@
+ if (info_ptr == NULL)
+ {
+ fclose(fp);
+- png_destroy_read_struct(&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, NULL, NULL);
+ return( -1 );
+ }
+
+@@ -89,7 +89,7 @@
+ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ fclose(fp);
+ /* If we get here, we had a problem reading the file */
+ return( -1 );
+@@ -109,7 +109,7 @@
+ * adjustment), then you can read the entire image (including
+ * pixels) into the info structure with this call:
+ */
+- png_read_png(png_ptr, info_ptr, PNG_TRANSFORM_IDENTITY, png_voidp_NULL);
++ png_read_png(png_ptr, info_ptr, PNG_TRANSFORM_IDENTITY, NULL);
+
+ /* At this point you have read the entire image */
+
+@@ -174,7 +174,7 @@
+ }
+
+ /* clean up after the read, and free any memory allocated - REQUIRED */
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+
+ /* close the file */
+ fclose(fp);
diff --git a/media-libs/ucil/metadata.xml b/media-libs/ucil/metadata.xml
new file mode 100644
index 000000000..7d7809e31
--- /dev/null
+++ b/media-libs/ucil/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <longdescription>The ucil library provides easy-to-use functions to render
+ text and graphic overlays onto video images.</longdescription>
+</pkgmetadata>
diff --git a/media-libs/ucil/ucil-0.9.8.ebuild b/media-libs/ucil/ucil-0.9.8.ebuild
new file mode 100644
index 000000000..c6c09f640
--- /dev/null
+++ b/media-libs/ucil/ucil-0.9.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Overlays text and graphics on video images"
+HOMEPAGE="http://unicap-imaging.org/"
+SRC_URI="http://unicap-imaging.org/downloads/lib${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug doc nls png theora"
+
+RDEPEND="dev-libs/glib:2
+ ~media-libs/unicap-${PV}
+ x11-libs/pango
+ alsa? ( media-libs/alsa-lib )
+ nls? ( virtual/libintl )
+ png? ( media-libs/libpng )
+ theora? ( media-libs/libtheora )"
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )"
+
+S=${WORKDIR}/lib${P}
+
+src_prepare() {
+ # patch submitted upstream at https://bugs.launchpad.net/unicap/+bug/584164
+ epatch "${FILESDIR}/libpng14.patch"
+}
+
+src_configure() {
+ # The Unicap author recommended leaving avcodec (ffmpeg) support disabled:
+ # http://unicap-imaging.org/blog/index.php?/archives/20-Unicap-0.9.3-and-UCView-0.22-released.html#c46
+
+ econf --disable-ucil-avcodec \
+ $(use_enable alsa ucil-alsa) \
+ $(use_enable debug debug-ucil) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable nls) \
+ $(use_enable png ucil-png) \
+ $(use_enable theora ucil-theora)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
diff --git a/media-libs/unicap/ChangeLog b/media-libs/unicap/ChangeLog
index 7bebc773b..b11e9f846 100644
--- a/media-libs/unicap/ChangeLog
+++ b/media-libs/unicap/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for media-libs/unicap
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 22 May 2010; Matt Whitlock (whitslack) <matt@whitlock.name>
+ -unicap-0.9.7.ebuild, +unicap-0.9.8.ebuild, metadata.xml:
+ new version: media-libs/unicap-0.9.8 (bug 175881)
+
+ Note: Upstream split the unicap library into three parts. This is one of
+ them, along with media-libs/unicapgtk and media-libs/ucil.
+
14 Oct 2009; Matt Whitlock (whitslack) <matt@whitlock.name>
-unicap-0.9.3.ebuild, +unicap-0.9.7.ebuild:
version bump to media-libs/unicap-0.9.7, added doc USE flag, added missing
diff --git a/media-libs/unicap/Manifest b/media-libs/unicap/Manifest
index 508e26a22..ee1f91093 100644
--- a/media-libs/unicap/Manifest
+++ b/media-libs/unicap/Manifest
@@ -1,4 +1,4 @@
-DIST unicap-0.9.7.tar.gz 1288916 RMD160 382ef621c091cef9d04b1595ed9d32e468181514 SHA1 de2c38b1c8eebf4f20e561b4629f67f4e56612bb SHA256 b3b7682718e64761d807a96236720cb2952219c139a21d343325fb25fe30cde2
-EBUILD unicap-0.9.7.ebuild 1784 RMD160 ee141be1606e8e6b8703464649728886b3006023 SHA1 4385f1b97319064c9aab7510c68afc5510250ecc SHA256 45027dcd599ae3b373b908ab57f6b0c58edd7d8df448547d15053c98c3053517
-MISC ChangeLog 476 RMD160 4b322c7dd28eac9bda8603ac30f0196d38cbb2be SHA1 0205ac81c296ac403d911206e043a963daa2b6c9 SHA256 8f3ab91cad9a8a58e024d041d2d9363ba72d3aa256f53a2fe580401391a3acca
-MISC metadata.xml 414 RMD160 94c0df6c78d876b88f3fd983e5bda62e3c35524c SHA1 0375a1ac0348546b9c1a72b03f5b1660cf5380b9 SHA256 62ea8b89f0d6fd301ffa58695dc84bd646e69016fb1a9c02c2d18da0d486f49a
+DIST libunicap-0.9.8.tar.gz 567118 RMD160 ef823e8ee639a3ef1c76e58627dc3b0c4a2af4e9 SHA1 4d3b46c454a362d1894ddb8cfaee4129072f9c60 SHA256 3057867c7259b500c058fe9ee8dd44adebed3241bdaf6ff0114b9627602f7860
+EBUILD unicap-0.9.8.ebuild 1309 RMD160 07e8bb98d6fe554731f3bd83952ecfce7da21ef8 SHA1 d07e7ec9f0f6638c4ed6e1cd945432d27bc8bfdb SHA256 e9f4fc9649ec5000c8ae901f89462648180b9a0ad4aa512acf1e45519444199e
+MISC ChangeLog 790 RMD160 0560715cce2b361da1099a8744b59971067d4155 SHA1 78e1172f765d086e69fff6e855d8f7257ae2ea04 SHA256 c4d6583b402534702a007f74d31fea2ab742c27cf6e8779ca3561ca7cfb5c52c
+MISC metadata.xml 502 RMD160 508989f9373f0485eed552fbd7dda8c7ecf364f4 SHA1 f781def6b4f5e52e18b9d52f02649a8a7084c5bc SHA256 6954c472e89829e258f707fe33dc3b429983f45fec3c40b2d35a83a48d357a72
diff --git a/media-libs/unicap/metadata.xml b/media-libs/unicap/metadata.xml
index b03e993dd..c818dbbdb 100644
--- a/media-libs/unicap/metadata.xml
+++ b/media-libs/unicap/metadata.xml
@@ -6,4 +6,7 @@
<longdescription>unicap provides a uniform interface to video capture
devices. It allows applications to use any supported video capture device
via a single API.</longdescription>
+ <use>
+ <flag name="libv4l">Use libv4l to communicate with v4l2 devices</flag>
+ </use>
</pkgmetadata>
diff --git a/media-libs/unicap/unicap-0.9.7.ebuild b/media-libs/unicap/unicap-0.9.7.ebuild
deleted file mode 100644
index e931750a1..000000000
--- a/media-libs/unicap/unicap-0.9.7.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-DESCRIPTION="The uniform API for image acquisition devices"
-HOMEPAGE="http://unicap-imaging.org/"
-SRC_URI="http://unicap-imaging.org/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa debug doc gtk ieee1394 nls png theora threads v4l v4l2"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- gtk? ( x11-libs/gtk+:2 )
- ieee1394? ( >=sys-libs/libraw1394-0.10.0 )
- nls? ( virtual/libintl )
- png? ( media-libs/libpng )
- theora? ( media-libs/libtheora )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-util/gtk-doc-1.4 )"
-
-src_configure() {
- local myconf
-
- if use debug ; then
- myconf="${myconf} --enable-thing --enable-debug-unicap
- --enable-debug-ucil --enable-debug-thing"
- use gtk && myconf="${myconf} --enable-debug-unicapgtk"
- use ieee1394 && myconf="${myconf} --enable-debug-dcam
- --enable-debug-vid21394"
- use v4l && myconf="${myconf} --enable-debug-v4l"
- use v4l2 && myconf="${myconf} --enable-debug-v4l2"
- fi
-
- # The Unicap author recommended leaving avcodec (ffmpeg) support disabled:
- # http://unicap-imaging.org/blog/index.php?/archives/20-Unicap-0.9.3-and-UCView-0.22-released.html#c46
-
- econf ${myconf} \
- $(use_enable alsa ucil-alsa) \
- $(use_enable doc gtk-doc) \
- $(use_enable gtk unicapgtk) \
- $(use_enable ieee1394 dcam) \
- $(use_enable ieee1394 vid21394) \
- $(use_enable nls) \
- $(use_enable png ucil-png) \
- $(use_enable theora ucil-theora) \
- $(use_enable threads unicap-threads) \
- $(use_enable v4l) \
- $(use_enable v4l2) \
- --enable-ucil
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README README.troubleshooting \
- || die "dodoc failed"
-}
diff --git a/media-libs/unicap/unicap-0.9.8.ebuild b/media-libs/unicap/unicap-0.9.8.ebuild
new file mode 100644
index 000000000..e2f9fe567
--- /dev/null
+++ b/media-libs/unicap/unicap-0.9.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+DESCRIPTION="The uniform API for image acquisition devices"
+HOMEPAGE="http://unicap-imaging.org/"
+SRC_URI="http://unicap-imaging.org/downloads/lib${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc ieee1394 libv4l nls threads v4l v4l2"
+
+RDEPEND="ieee1394? ( sys-libs/libraw1394 )
+ nls? ( virtual/libintl )
+ v4l2? ( libv4l? ( media-libs/libv4l ) )"
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )"
+
+S=${WORKDIR}/lib${P}
+
+src_configure() {
+ local -a myconf
+
+ if use debug ; then
+ # thing is presently broken (sloppy upstream)
+ #myconf=( --enable-thing )
+ myconf+=( --enable-debug-unicap --enable-debug-ucil --enable-debug-thing )
+ use ieee1394 && myconf+=( --enable-debug-dcam --enable-debug-vid21394 )
+ use v4l && myconf+=( --enable-debug-v4l )
+ use v4l2 && myconf+=( --enable-debug-v4l2 )
+ fi
+
+ econf "${myconf[@]}" \
+ $(use_enable doc gtk-doc) \
+ $(use_enable ieee1394 dcam) \
+ $(use_enable ieee1394 vid21394) \
+ $(use_enable libv4l ) \
+ $(use_enable nls) \
+ $(use_enable threads unicap-threads) \
+ $(use_enable v4l) \
+ $(use_enable v4l2)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
diff --git a/media-libs/unicapgtk/ChangeLog b/media-libs/unicapgtk/ChangeLog
new file mode 100644
index 000000000..79a2f51be
--- /dev/null
+++ b/media-libs/unicapgtk/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-libs/unicapgtk
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 22 May 2010; Matt Whitlock (whitslack) <matt@whitlock.name>
+ +unicapgtk-0.9.8.ebuild, +metadata.xml:
+ new ebuild: media-libs/unicapgtk-0.9.8 (bug 175881)
+
+ Note: Upstream split the unicap library into three parts. This is one of
+ them, along with media-libs/unicap and media-libs/ucil.
+
diff --git a/media-libs/unicapgtk/Manifest b/media-libs/unicapgtk/Manifest
new file mode 100644
index 000000000..f6f986b78
--- /dev/null
+++ b/media-libs/unicapgtk/Manifest
@@ -0,0 +1,4 @@
+DIST libunicapgtk-0.9.8.tar.gz 444190 RMD160 edcb8424a7f9e49894a126744e2baef26ccfa02d SHA1 03ccc74f605a8b9b4dd360f6f67f08db00627611 SHA256 fc6249058279adde3a20aab6e506463baf1d1f05cf5369ad4a858a3c5b5885a6
+EBUILD unicapgtk-0.9.8.ebuild 745 RMD160 cd1c1e23d6da161b727ab0b11f8f1038ff578e53 SHA1 8959cb67958efc27668962fa5b845287b82db234 SHA256 6ba760aa63c0614c234f02d44225719fa3c208699755330bfab9b09792cbf60b
+MISC ChangeLog 416 RMD160 4ce863a5dcb198f62501213f4c3dcf471af0478d SHA1 883e7884c3390b4b0c1d92b04f03562a6651fe69 SHA256 ad339629c04e3d82e2f21ffa1fc9ff067b18268e52bb0401714f53f745f0b6c4
+MISC metadata.xml 256 RMD160 e700298688f198e671e13e96fd930282bfcff17e SHA1 eec2687b50f18ca1af7396e75209713f44436a42 SHA256 e0cf06d30024aa7cbf2f0807f2baba06094e57a624997bc55b129181a8b2837f
diff --git a/media-libs/unicapgtk/metadata.xml b/media-libs/unicapgtk/metadata.xml
new file mode 100644
index 000000000..1b191b741
--- /dev/null
+++ b/media-libs/unicapgtk/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <longdescription>GTK2 widget for the unicap video capture library</longdescription>
+</pkgmetadata>
diff --git a/media-libs/unicapgtk/unicapgtk-0.9.8.ebuild b/media-libs/unicapgtk/unicapgtk-0.9.8.ebuild
new file mode 100644
index 000000000..0d0b3489b
--- /dev/null
+++ b/media-libs/unicapgtk/unicapgtk-0.9.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+DESCRIPTION="GTK2 widget for the unicap video capture library"
+HOMEPAGE="http://unicap-imaging.org/"
+SRC_URI="http://unicap-imaging.org/downloads/lib${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc nls"
+
+RDEPEND="~media-libs/unicap-${PV}
+ x11-libs/gtk+:2
+ x11-libs/libXv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )"
+
+S=${WORKDIR}/lib${P}
+
+src_configure() {
+ econf \
+ $(use_enable debug debug-unicapgtk) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+}