summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Garthe (the_mgt) <themgt@uncensored.citadel.org>2011-06-21 18:23:23 +0000
committerStefan Garthe (the_mgt) <themgt@uncensored.citadel.org>2011-06-21 18:23:23 +0000
commit93018cf28704a616cfc1442d25f944e525d4b18d (patch)
treee1f19699d07d7c4b8201f517388d02dc0791f2c5 /games-rpg/lipsofsuna
parentdev-python/parsedatetime: Support multiple python ABIs, rewrite testing and d... (diff)
downloadsunrise-reviewed-93018cf28704a616cfc1442d25f944e525d4b18d.tar.gz
sunrise-reviewed-93018cf28704a616cfc1442d25f944e525d4b18d.tar.bz2
sunrise-reviewed-93018cf28704a616cfc1442d25f944e525d4b18d.zip
games-rpg/lipsofsuna: New Ebuild for bug #372501, thanks to mgorny, floppym and Enlik for review and suggestions
svn path=/sunrise/; revision=12148
Diffstat (limited to 'games-rpg/lipsofsuna')
-rw-r--r--games-rpg/lipsofsuna/ChangeLog9
-rw-r--r--games-rpg/lipsofsuna/Manifest5
-rw-r--r--games-rpg/lipsofsuna/lipsofsuna-0.4.0.ebuild46
-rw-r--r--games-rpg/lipsofsuna/lipsofsuna-9999.ebuild49
-rw-r--r--games-rpg/lipsofsuna/metadata.xml23
5 files changed, 132 insertions, 0 deletions
diff --git a/games-rpg/lipsofsuna/ChangeLog b/games-rpg/lipsofsuna/ChangeLog
new file mode 100644
index 000000000..a9060c516
--- /dev/null
+++ b/games-rpg/lipsofsuna/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for games-rpg/lipsofsuna
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 21 Jun 2011; the_mgt themgt@uncensored.citadel.org
+ +lipsofsuna-0.4.0.ebuild, +lipsofsuna-9999.ebuild, +metadata.xml:
+ New Ebuild for bug #372501, thanks to mgorny, floppym and Enlik for review
+ and suggestions
+
diff --git a/games-rpg/lipsofsuna/Manifest b/games-rpg/lipsofsuna/Manifest
new file mode 100644
index 000000000..ed25f28af
--- /dev/null
+++ b/games-rpg/lipsofsuna/Manifest
@@ -0,0 +1,5 @@
+DIST lipsofsuna-0.4.0.tar.gz 91584801 RMD160 02c85687847c3cd087aaeb2009194210881410f8 SHA1 a1b008e615e6d9513add8320a1c2038971d8402c SHA256 1fa26da8727559d3c9557935578c3f363c6259aa9d5636e8b103894d80344ecd
+EBUILD lipsofsuna-0.4.0.ebuild 1145 RMD160 00060a49fd35d9f59dd3d7401e1268dbd0bf6930 SHA1 5652cdd415341880576e07b521276737f20ceb94 SHA256 019afa8cb0264f126f91b48b1ddb2f046df46f0b0f77a8c145059f7b175fd61d
+EBUILD lipsofsuna-9999.ebuild 1205 RMD160 986e06ed7d67ffe1c950cbc119c365e06bfa7c9e SHA1 19c7c492f201fb1cc2ac07064f45d2f10d753010 SHA256 32869db32bd8ee5bbcd8c0ab58422e0e9ce779ccb2b8dc78c6df4be2534abd45
+MISC ChangeLog 338 RMD160 4150ba17c4b958c4cb439e0ab1196ea6c9119262 SHA1 32fe891763e44bb201f47316f87ede7412b690c7 SHA256 6deba8e891b089c0e1b7777be0646ba6cacbe52979418f4641d6f4853e872144
+MISC metadata.xml 1057 RMD160 1808727566b17b79cdf45c4781d7d7eac356c5f6 SHA1 eb4a909f96d2fff432fb2254a5f1dec2d1ade65f SHA256 4f9142580ec3ac8ecee65c3a403429db68c0a40332736d03824abbcb316fc5a8
diff --git a/games-rpg/lipsofsuna/lipsofsuna-0.4.0.ebuild b/games-rpg/lipsofsuna/lipsofsuna-0.4.0.ebuild
new file mode 100644
index 000000000..acf784c1d
--- /dev/null
+++ b/games-rpg/lipsofsuna/lipsofsuna-0.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit eutils games waf-utils
+
+DESCRIPTION="Tongue-in-cheek dungeon crawl game. Client and Server."
+HOMEPAGE="http://lipsofsuna.org/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-db/sqlite:3
+ >=dev-lang/lua-5.1.0
+ media-libs/flac
+ >=media-libs/glew-1.5
+ >=media-libs/libsdl-1.2
+ media-libs/libvorbis
+ media-libs/libogg
+ media-libs/mesa
+ media-libs/openal
+ >=media-libs/sdl-ttf-2.0
+ >=net-libs/enet-1
+ >=net-misc/curl-3
+ sci-physics/bullet"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ waf-utils_src_configure \
+ --relpath=false --optimize=true \
+ --bindir="${GAMES_BINDIR}" \
+ --datadir="${GAMES_DATADIR}"
+}
+
+src_install() {
+ dogamesbin .build/${PN} || die "Installation of gamesbinary failed"
+ insinto "${GAMES_DATADIR}"/${PN}/
+ doins -r data/* || die "Installation of game data failed"
+ doicon misc/${PN}.svg || die "Installation of Icon failed"
+ domenu misc/${PN}.desktop || die "Installation of desktop file failed"
+ prepgamesdirs
+}
diff --git a/games-rpg/lipsofsuna/lipsofsuna-9999.ebuild b/games-rpg/lipsofsuna/lipsofsuna-9999.ebuild
new file mode 100644
index 000000000..f74e2d55e
--- /dev/null
+++ b/games-rpg/lipsofsuna/lipsofsuna-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+EGIT_REPO_URI="git://lipsofsuna.git.sourceforge.net/gitroot/lipsofsuna/lipsofsuna"
+EGIT_PROJECT="lipsofsuna"
+inherit eutils games waf-utils git-2
+
+DESCRIPTION="Tongue-in-cheek dungeon crawl game. Client and Server"
+HOMEPAGE="http://lipsofsuna.org/"
+SRC_URI=""
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-db/sqlite:3
+ >=dev-lang/lua-5.1.0
+ media-libs/flac
+ >=media-libs/glew-1.5
+ >=media-libs/libsdl-1.2
+ media-libs/libvorbis
+ media-libs/libogg
+ media-libs/mesa
+ media-libs/openal
+ >=media-libs/sdl-ttf-2.0
+ >=net-libs/enet-1
+ >=net-misc/curl-3
+ sci-physics/bullet"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ waf-utils_src_configure \
+ --relpath=false --optimize=true \
+ --bindir="${GAMES_BINDIR}" \
+ --datadir="${GAMES_DATADIR}"
+}
+
+src_install() {
+ dogamesbin .build/${PN} || die "Installation of gamesbinary failed"
+ insinto "${GAMES_DATADIR}"/${PN}/
+ doins -r data/* || die "Installation of game data failed"
+ doicon misc/${PN}.svg || die "Installation of Icon failed"
+ domenu misc/${PN}.desktop || die "Installation of desktop file failed"
+ prepgamesdirs
+}
diff --git a/games-rpg/lipsofsuna/metadata.xml b/games-rpg/lipsofsuna/metadata.xml
new file mode 100644
index 000000000..77a02396b
--- /dev/null
+++ b/games-rpg/lipsofsuna/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+ <longdescription>Lips of Suna is a tongue-in-cheek dungeon crawl game that
+ takes place in the chaotic dungeons of Suna. The five intelligent
+ races of the world descend to the dungeons with their goal to save
+ the world from a conclusive disaster.
+ In your journey to the depths of the dungeons, you will, among other
+ things, have to fight creatures of different varieties, solve quests,
+ explore new places, and craft custom items. Luckily you don't need to
+ do all this alone since you can crawl the dungeons with your friends.
+ </longdescription>
+ <upstream>
+ <maintainer>
+ <email>amuzen@users.sourceforge.net</email>
+ <name>Ari Mustonen</name>
+ </maintainer>
+ <doc>http://sourceforge.net/apps/trac/lipsofsuna/wiki</doc>
+ <bugs-to>http://sourceforge.net/apps/trac/lipsofsuna/report</bugs-to>
+ </upstream>
+</pkgmetadata>