aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/skymaker/skymaker-9999.ebuild')
-rw-r--r--sci-astronomy/skymaker/skymaker-9999.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/sci-astronomy/skymaker/skymaker-9999.ebuild b/sci-astronomy/skymaker/skymaker-9999.ebuild
index f44f47f96..171e6c83d 100644
--- a/sci-astronomy/skymaker/skymaker-9999.ebuild
+++ b/sci-astronomy/skymaker/skymaker-9999.ebuild
@@ -1,23 +1,15 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-if [[ ${PV} == "9999" ]] ; then
- inherit subversion
- ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
+inherit subversion
-#AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-inherit autotools-utils
+ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ESVN_OPTIONS="--trust-server-cert-failures=unknown-ca"
+SRC_URI=""
+KEYWORDS=""
DESCRIPTION="Program that simulates astronomical images"
HOMEPAGE="http://www.astromatic.net/software/skymaker"
@@ -29,7 +21,11 @@ IUSE="threads"
RDEPEND="sci-libs/fftw:3.0"
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ subversion_src_prepare
+}
+
src_configure() {
- local myeconfargs=( $(use_enable threads) )
- autotools-utils_src_configure
+ econf $(use_enable threads)
}