aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-05-14 13:49:02 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-05-14 13:49:02 +0200
commit7a4c5e17a64afe18b4af992e6b2df279ecd9e7e6 (patch)
treed5f0f2426d71be9b5a3400743a08e1585ae51317 /sci-biology/SPAdes
parentsci-biology/SPAdes: fix compile issue but drop KEYWORDS because of QA issues (diff)
downloadsci-7a4c5e17a64afe18b4af992e6b2df279ecd9e7e6.tar.gz
sci-7a4c5e17a64afe18b4af992e6b2df279ecd9e7e6.tar.bz2
sci-7a4c5e17a64afe18b4af992e6b2df279ecd9e7e6.zip
sci-biology/SPAdes: install the package directly using cmake
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sci-biology/SPAdes')
-rw-r--r--sci-biology/SPAdes/SPAdes-3.10.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sci-biology/SPAdes/SPAdes-3.10.1.ebuild b/sci-biology/SPAdes/SPAdes-3.10.1.ebuild
index 73050c1e4..de93157a4 100644
--- a/sci-biology/SPAdes/SPAdes-3.10.1.ebuild
+++ b/sci-biology/SPAdes/SPAdes-3.10.1.ebuild
@@ -68,12 +68,14 @@ src_prepare(){
}
src_compile(){
- # grr, it actually also installs the files into $DESTDIR but that is purged before pkg_qmerge starts
- PREFIX="${D}"/usr ./spades_compile.sh || die
+ mkdir build_spades || die
+ cd build_spades || die
+ cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX="${ED}/usr" $* "${S}/src" || die
}
src_install(){
- PREFIX="${ED}"/usr sh ./spades_install.sh || die
+ cd build_spades || die
+ emake install PREFIX="${ED}"/usr
# BUG: move *.py files to standard site-packages/ subdirectories
insinto /usr/share/"${PN}"
dodoc "${DISTDIR}"/${P}_*manual.html