aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 16:37:21 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:35 +0200
commit0851b80abdf50cf2d504d0af23e6645158faca92 (patch)
tree26a2ab0c03929d6573b5cdec97e652e0580bbee1 /dev-python/asdf-standard/asdf-standard-1.1.1.ebuild
parentsci-physics/mplhep: new package, add 0.3.53 (diff)
downloadsci-0851b80abdf50cf2d504d0af23e6645158faca92.tar.gz
sci-0851b80abdf50cf2d504d0af23e6645158faca92.tar.bz2
sci-0851b80abdf50cf2d504d0af23e6645158faca92.zip
dev-python/asdf*: add 3.5.0
Co-authored-by: Nowa Ammerlaan <andrewammerlaan@gentoo.org> Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'dev-python/asdf-standard/asdf-standard-1.1.1.ebuild')
-rw-r--r--dev-python/asdf-standard/asdf-standard-1.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/asdf-standard/asdf-standard-1.1.1.ebuild b/dev-python/asdf-standard/asdf-standard-1.1.1.ebuild
new file mode 100644
index 000000000..55db6e6d0
--- /dev/null
+++ b/dev-python/asdf-standard/asdf-standard-1.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Standards document describing ASDF, Advanced Scientific Data Format."
+HOMEPAGE="
+ https://github.com/asdf-format/asdf-standard/
+ https://pypi.org/project/asdf-standard/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/asdf-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest