aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-04-07 22:15:31 +0200
committerFabian Groffen <grobian@gentoo.org>2019-04-07 22:15:31 +0200
commitf74766218c33e762e272f9f0129128a9f8ffd4a9 (patch)
tree117df1f80f3af16e4179c990c5d777ad2ebe5142 /libq/Makefile.in
parentatoms: add proper support for blockers and USE dependencies (diff)
downloadportage-utils-f74766218c33e762e272f9f0129128a9f8ffd4a9.tar.gz
portage-utils-f74766218c33e762e272f9f0129128a9f8ffd4a9.tar.bz2
portage-utils-f74766218c33e762e272f9f0129128a9f8ffd4a9.zip
qdepends: rewrite to better match forward/backward dependencies
- dep: extract dependency functions into separate files for later reuse - by default, report all deps for all *DEPEND combined (duplicates removed) - allow listing per *DEPEND using -v, pretty-print and highlight the atoms seleted or queried for (-Q) - support reverse querying multiple atoms - make -Q output match forward output, highlight the match, to just print the match, use -q Bug: https://bugs.gentoo.org/682056 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'libq/Makefile.in')
-rw-r--r--libq/Makefile.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/libq/Makefile.in b/libq/Makefile.in
index ab7012f..935747e 100644
--- a/libq/Makefile.in
+++ b/libq/Makefile.in
@@ -243,7 +243,7 @@ LTLIBRARIES = $(noinst_LTLIBRARIES)
libq_la_LIBADD =
am__objects_1 = libq_la-atom.lo libq_la-basename.lo libq_la-cache.lo \
libq_la-colors.lo libq_la-contents.lo libq_la-copy_file.lo \
- libq_la-eat_file.lo libq_la-hash_fd.lo \
+ libq_la-dep.lo libq_la-eat_file.lo libq_la-hash_fd.lo \
libq_la-human_readable.lo libq_la-md5_sha1_sum.lo \
libq_la-prelink.lo libq_la-profile.lo libq_la-rmspace.lo \
libq_la-safe_io.lo libq_la-scandirat.lo libq_la-set.lo \
@@ -1450,6 +1450,7 @@ QFILES = \
colors.c colors.h \
contents.c contents.h \
copy_file.c copy_file.h \
+ dep.c dep.h \
eat_file.c eat_file.h \
hash_fd.c hash_fd.h \
human_readable.c human_readable.h \
@@ -1537,6 +1538,7 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libq_la-colors.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libq_la-contents.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libq_la-copy_file.Plo@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libq_la-dep.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libq_la-eat_file.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libq_la-hash_fd.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libq_la-human_readable.Plo@am__quote@
@@ -1618,6 +1620,13 @@ libq_la-copy_file.lo: copy_file.c
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(libq_la_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o libq_la-copy_file.lo `test -f 'copy_file.c' || echo '$(srcdir)/'`copy_file.c
+libq_la-dep.lo: dep.c
+@am__fastdepCC_TRUE@ $(AM_V_CC)$(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(libq_la_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT libq_la-dep.lo -MD -MP -MF $(DEPDIR)/libq_la-dep.Tpo -c -o libq_la-dep.lo `test -f 'dep.c' || echo '$(srcdir)/'`dep.c
+@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/libq_la-dep.Tpo $(DEPDIR)/libq_la-dep.Plo
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='dep.c' object='libq_la-dep.lo' libtool=yes @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(libq_la_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o libq_la-dep.lo `test -f 'dep.c' || echo '$(srcdir)/'`dep.c
+
libq_la-eat_file.lo: eat_file.c
@am__fastdepCC_TRUE@ $(AM_V_CC)$(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(libq_la_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT libq_la-eat_file.lo -MD -MP -MF $(DEPDIR)/libq_la-eat_file.Tpo -c -o libq_la-eat_file.lo `test -f 'eat_file.c' || echo '$(srcdir)/'`eat_file.c
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/libq_la-eat_file.Tpo $(DEPDIR)/libq_la-eat_file.Plo