aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gmail.com>2023-01-10 21:52:01 -0800
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-17 22:49:46 +0200
commitf1c58b74df5eab2dac1e8e5810d9a042785f60cc (patch)
tree0777fb49614d0517097a8e4b6a69cd29a074178d /tests
parentfix(config): add exception chaining for an internal error. (diff)
downloadpkgcore-f1c58b74df5eab2dac1e8e5810d9a042785f60cc.tar.gz
pkgcore-f1c58b74df5eab2dac1e8e5810d9a042785f60cc.tar.bz2
pkgcore-f1c58b74df5eab2dac1e8e5810d9a042785f60cc.zip
refactor(portage_conf): Push fallback (and path awareness) logic of repos.conf into methods.
The previous code had the exception + fallback handling in the init; this is already a long init, and there are changes needed for repos conf, thus introduce a method to do the fallback logic. Said method will be extended to essentially bury the complexity of repos.conf- that problem- into an encapsulated method to try and reduce the cognitive burden of dealing with it. Why this matters: this work is prep for extension of repos.conf to add in various syncing features portage grew over the last decade+. Signed-off-by: Brian Harring <ferringb@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'tests')
-rw-r--r--tests/ebuild/test_portage_conf.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/ebuild/test_portage_conf.py b/tests/ebuild/test_portage_conf.py
index edb3d89b6..b939ee09e 100644
--- a/tests/ebuild/test_portage_conf.py
+++ b/tests/ebuild/test_portage_conf.py
@@ -13,7 +13,7 @@ from pkgcore.config import errors as config_errors
from pkgcore.ebuild.portage_conf import PortageConfig
load_make_conf = PortageConfig.load_make_conf
-load_repos_conf = PortageConfig.load_repos_conf
+load_repos_conf = PortageConfig.parse_repos_conf_path
class TestMakeConf: