summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-10-01 18:51:09 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-10-01 18:51:09 +0000
commite4153a320eae015657ac073999227f00dd201612 (patch)
tree5fe8496544a0e0ee695d3c530ef34e97e2aae97e
parentCorrect ~nx ownership, this fixes my bug at: (diff)
downloadnx-e4153a320eae015657ac073999227f00dd201612.tar.gz
nx-e4153a320eae015657ac073999227f00dd201612.tar.bz2
nx-e4153a320eae015657ac073999227f00dd201612.zip
Old, current version is in portage
svn path=/testing/; revision=239
-rw-r--r--metadata/cache/net-misc/neatx-0.3.1_p4122
-rw-r--r--net-misc/neatx/Manifest1
-rw-r--r--net-misc/neatx/neatx-0.3.1_p42.ebuild107
3 files changed, 0 insertions, 130 deletions
diff --git a/metadata/cache/net-misc/neatx-0.3.1_p41 b/metadata/cache/net-misc/neatx-0.3.1_p41
deleted file mode 100644
index b9ff71e..0000000
--- a/metadata/cache/net-misc/neatx-0.3.1_p41
+++ /dev/null
@@ -1,22 +0,0 @@
-dev-python/docutils =sys-devel/automake-1.10* >=sys-devel/autoconf-2.61 sys-devel/libtool virtual/python dev-util/subversion net-misc/rsync
-dev-python/pexpect dev-python/simplejson >=dev-python/pygtk-2.14 >=dev-python/pygobject-2.14 app-portage/portage-utils media-fonts/font-misc-misc media-fonts/font-cursor-misc net-analyzer/netcat net-misc/nx
-0
-
-
-http://code.google.com/p/neatx/
-GPL-2
-Google implementation of NX server
-~x86 ~amd64
-autotools distutils eutils libtool multilib portability python subversion toolchain-funcs
-
-
-
-
-2
-
-compile install postinst postrm preinst prepare setup unpack
-
-
-
-
-
diff --git a/net-misc/neatx/Manifest b/net-misc/neatx/Manifest
deleted file mode 100644
index 23a678c..0000000
--- a/net-misc/neatx/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-EBUILD neatx-0.3.1_p42.ebuild 2928 RMD160 df7e9fa7e375ebe67c3531d54f16a46d56e21f2b SHA1 156ef8d0e6403c326dc7e23ccee0dbd6556bc282 SHA256 ea16b3aec5a91bf4561cb572551182c5c8bcafacf34bcc94480c57063e5197b8
diff --git a/net-misc/neatx/neatx-0.3.1_p42.ebuild b/net-misc/neatx/neatx-0.3.1_p42.ebuild
deleted file mode 100644
index e13c80a..0000000
--- a/net-misc/neatx/neatx-0.3.1_p42.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit eutils autotools distutils subversion
-
-REV="${PV/[0-9.]*\_p}"
-ESVN_REPO_URI="http://neatx.googlecode.com/svn/trunk/neatx@${REV}"
-
-DESCRIPTION="Google implementation of NX server"
-HOMEPAGE="http://code.google.com/p/neatx/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-
-DEPEND="dev-python/docutils"
-RDEPEND="dev-python/pexpect
- dev-python/simplejson
- >=dev-python/pygtk-2.14
- >=dev-python/pygobject-2.14
- app-portage/portage-utils
- media-fonts/font-misc-misc
- media-fonts/font-cursor-misc
- net-analyzer/netcat
- net-misc/nx"
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- sed -i -e "s/rst2html]/rst2html.py]/" configure.ac \
- || die "configure.ac sed failed"
- sed -i -e "s#/lib/neatx#/neatx#" Makefile.am \
- || die "Makefile.am sed failed"
- sed -e "/DATA_DIR =/s#/lib/neatx#/neatx#" \
- -i lib/constants.py || die "constants.py sed failed"
-
- eautoreconf
-
- # This is for bug 215944, so .pyo/.pyc files don't get into the
- # file system
- mv "${S}"/autotools/py-compile "${S}"/autotools/py-compile.orig
- ln -s $(type -P true) "${S}"/autotools/py-compile
-}
-
-pkg_setup () {
- if [ -z "${NX_HOME_DIR}" ];
- then
- export NX_HOME_DIR=/var/lib/neatx/home
- fi
- enewuser nx -1 -1 ${NX_HOME_DIR}
-}
-
-src_compile() {
- default_src_compile
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "Failed to install"
- fperms 777 /var/lib/neatx/sessions
- dodir ${NX_HOME_DIR}/.ssh
- fowners nx:nx ${NX_HOME_DIR}
- fowners nx:nx ${NX_HOME_DIR}/.ssh
-
- insinto /etc
- newins doc/neatx.conf.example neatx.conf
- cat >> "${D}"/etc/neatx.conf << EOF
-
-netcat-path = /usr/bin/netcat
-xserssion-path = /etc/X11/Sessions/Xsession
-use-xsession = false
-EOF
-
- insinto ${NX_HOME_DIR}/.ssh
- insopts -m 600 -o nx
- newins extras/authorized_keys.nomachine authorized_keys
-}
-
-pkg_postinst () {
- distutils_pkg_postinst
-
- # Other NX servers ebuilds may have already created the nx account
- # However they use different login shell/home directory paths
- if [[ ${ROOT} == "/" ]]; then
- usermod -s /usr/$(get_libdir)/neatx/nxserver-login nx || die "Unable to set login shell of nx user!!"
- usermod -d ${NX_HOME_DIR} nx || die "Unable to set home directory of nx user!!"
- else
- elog "If you had another NX server installed before, please make sure"
- elog "the nx user account is correctly set to:"
- elog " * login shell: /usr/$(get_libdir)/neatx/nxserver-login"
- elog " * home directory: ${NX_HOME_DIR}"
- fi
-
- if ! built_with_use net-misc/openssh pam; then
- elog ""
- elog "net-misc/openssh was not built with PAM support"
- elog "You will need to unlock the nx account by setting a password for it"
- fi
-
- elog "If you want to use the default su authentication (rather than ssh)"
- elog "you must ensure that the nx user is a member of the wheel group."
- elog "You can add it via \"usermod -a -G wheel nx\""
-}