summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-17 01:55:56 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-17 01:55:56 +0100
commitb2acb6e8c9967432ac93905e707d5217f926f9cb (patch)
treee063e4a1d3014acd92c46bd48ae7f6375426ed38
parentmariadb: Add new patch for binutil-libs 2.34 API change (diff)
downloadmysql-extras-b2acb6e8c9967432ac93905e707d5217f926f9cb.tar.gz
mysql-extras-b2acb6e8c9967432ac93905e707d5217f926f9cb.tar.bz2
mysql-extras-b2acb6e8c9967432ac93905e707d5217f926f9cb.zip
Fix 20018_all_*-8.0.*-without-clientlibs-tools.patchmysql-extras-20200317-0103Z
ICU is not required when building client tools only. Bug: https://bugs.gentoo.org/712072 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--20018_all_mysql-8.0.19-without-clientlibs-tools.patch13
-rw-r--r--20018_all_percona-server-8.0.18-without-clientlibs-tools.patch13
2 files changed, 24 insertions, 2 deletions
diff --git a/20018_all_mysql-8.0.19-without-clientlibs-tools.patch b/20018_all_mysql-8.0.19-without-clientlibs-tools.patch
index ea6744e..722ddac 100644
--- a/20018_all_mysql-8.0.19-without-clientlibs-tools.patch
+++ b/20018_all_mysql-8.0.19-without-clientlibs-tools.patch
@@ -1,6 +1,17 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1285,7 +1285,9 @@ IF(WITH_UNIT_TESTS)
+@@ -1200,7 +1200,9 @@ ENDIF()
+ # Add lz4 library
+ MYSQL_CHECK_LZ4()
+ # Add icu library
+-MYSQL_CHECK_ICU()
++IF(NOT WITHOUT_SERVER)
++ MYSQL_CHECK_ICU()
++ENDIF()
+ # Add SASL library
+ MYSQL_CHECK_SASL()
+ # Add protoc and libprotobuf
+@@ -1285,7 +1287,9 @@ IF(WITH_UNIT_TESTS)
INCLUDE(googletest)
ENDIF()
diff --git a/20018_all_percona-server-8.0.18-without-clientlibs-tools.patch b/20018_all_percona-server-8.0.18-without-clientlibs-tools.patch
index bf07285..0b466ea 100644
--- a/20018_all_percona-server-8.0.18-without-clientlibs-tools.patch
+++ b/20018_all_percona-server-8.0.18-without-clientlibs-tools.patch
@@ -1,6 +1,17 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1284,7 +1284,9 @@ IF(WITH_UNIT_TESTS)
+@@ -1199,7 +1199,9 @@ ENDIF()
+ # Add lz4 library
+ MYSQL_CHECK_LZ4()
+ # Add icu library
+-MYSQL_CHECK_ICU()
++IF(NOT WITHOUT_SERVER)
++ MYSQL_CHECK_ICU()
++ENDIF()
+ # Add SASL library
+ MYSQL_CHECK_SASL()
+ # Add protoc and libprotobuf
+@@ -1284,7 +1286,9 @@ IF(WITH_UNIT_TESTS)
INCLUDE(googletest)
ENDIF()