aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/tdb')
-rw-r--r--sys-libs/tdb/Manifest6
-rw-r--r--sys-libs/tdb/files/tdb-remove-check-bsd-strtoll.patch25
-rw-r--r--sys-libs/tdb/metadata.xml9
-rw-r--r--sys-libs/tdb/tdb-1.2.11-r99.ebuild46
-rw-r--r--sys-libs/tdb/tdb-1.2.12-r99.ebuild44
5 files changed, 130 insertions, 0 deletions
diff --git a/sys-libs/tdb/Manifest b/sys-libs/tdb/Manifest
new file mode 100644
index 00000000..92e876f1
--- /dev/null
+++ b/sys-libs/tdb/Manifest
@@ -0,0 +1,6 @@
+AUX tdb-remove-check-bsd-strtoll.patch 1181 SHA256 f1f90725967b0df76b24613c8382cd1b93f7717b49a2981b3ff5d36a49b7e7c6 SHA512 ccafbfaee3984a15e81cdd891d47d1100f221f2a22150f8cc14f0d2eed1d1412dcf7cad99cf3bb845825e6a75ac0d33331b26e07b17f718c40ab8b9aac8b935a WHIRLPOOL 8f2703ba60e898d7d1306712856bfb277d168a26845e754172f2451b6f8439f6f2d6f395b2a5d527b41b630c79c709f2fe26872a3e634989423afb4226a52d7b
+DIST tdb-1.2.11.tar.gz 481298 SHA256 f10eae6361b033131d2deebfcccbcaeb3d8006747005f5240d68e8b70632f6c2 SHA512 fba47db71d0a28eb38cac44a7aa5796d9ee54ab7a9fff3b5a88f9c305cbfb6580173a2cbe3a3ea3484ff0d366b7bc79be78512183216c484246688de5843d3bc WHIRLPOOL d3a1d61dd923ecd1c84d5d4299561a654b4eddc34282c505bb2e1507f7e673dea61c8b76a4f346ddd50fc3192905322a2efdd767dda591beb917d1166e833ced
+DIST tdb-1.2.12.tar.gz 462590 SHA256 282d3db1cc56ac3011ae5f3922fd0c5bb217ecb0320836c23b6fe67f2163a71f SHA512 7f6061cae722db79a604ed517e615bed8d06c1b69549e6c1b771611797e1b4f64ebc7af63c3b911ed055979dd6782c8fca44af829c3466911f4181e835ef9b28 WHIRLPOOL 1f584052432c2b87b3d203dd2aefdf9fb425181e5bbd2cfd2f23ede512fa01623f08c33e85afdddfb3c08d776892c15382d9868bfb22a4a36987e06668ffc828
+EBUILD tdb-1.2.11-r99.ebuild 1090 SHA256 103cda52f038a3d851bff5856d88360df56d2c97635e776c072c834db6ca6561 SHA512 99d38b5a7c228695148177d0597875fd227807beb270b6cfe025dd2e2dd779d2784ae27d11d119b5d9265514d2886eb970c4c385fe7931e5546ac75d39b4ecaa WHIRLPOOL 746bdbb98b38b32a78fc6595c9be832bc86a4da3072328c603ee70c821ddadfb804f560e27dce62b378f51b42224a4d666bb5e42183637eb8e9761372660a959
+EBUILD tdb-1.2.12-r99.ebuild 1021 SHA256 7496a54b221b3fb00c4c9e26581c2dce3b5af66e9a5d23986605f3de6f0fb5a0 SHA512 ec640d09c237d137fa63d44c9331d3257cb5bd614a18d0e112c41fcaf6996d8a11edecfdcd7691895cecdb53e89da8ba1aff247e975cbc5d5b3ca89eb7dbbb88 WHIRLPOOL 95031b9eefafebc3f3fd793997393d75776d97d25ce7b1472484fbe582293fa3dd0e7da75b8823aebe5b298283872f7f13df4f1daec5c7c1854bbfe33eac8360
+MISC metadata.xml 260 SHA256 9c67a75d6c6db8d88233eb27271c93874a4b763907a61f189970574fc957e0e6 SHA512 611e0004aba6d842ba71a9b9f74b8301d1a7d8d366208122001f5d164ae34b88c1ba2d41c0b25c760cea155387e5e7a4b3d141d6b21cc997f894a21c519a07c9 WHIRLPOOL 1bf0ee15987eee963adc9506dff9e8e978bcb8b7bdc9381f468fdc92ed39e356c69dc67af161da4eac8b46098a28ab8b6249f0efeb5709f7cd4f3f8a4749b675
diff --git a/sys-libs/tdb/files/tdb-remove-check-bsd-strtoll.patch b/sys-libs/tdb/files/tdb-remove-check-bsd-strtoll.patch
new file mode 100644
index 00000000..8108209a
--- /dev/null
+++ b/sys-libs/tdb/files/tdb-remove-check-bsd-strtoll.patch
@@ -0,0 +1,25 @@
+diff -Naur tdb-1.2.11.orig/lib/replace/wscript tdb-1.2.11/lib/replace/wscript
+--- tdb-1.2.11.orig/lib/replace/wscript 2012-11-30 08:51:31.000000000 +0000
++++ tdb-1.2.11/lib/replace/wscript 2014-02-23 12:37:58.921617847 +0000
+@@ -215,21 +215,6 @@
+
+ #Some OS (ie. freebsd) return EINVAL if the convertion could not be done, it's not what we expect
+ #Let's detect those cases
+- if conf.CONFIG_SET('HAVE_STRTOLL'):
+- conf.CHECK_CODE('''
+- long long nb = strtoll("Text", NULL, 0);
+- if (errno == EINVAL) {
+- return 0;
+- } else {
+- return 1;
+- }
+- ''',
+- msg="Checking correct behavior of strtoll",
+- headers = 'errno.h',
+- execute = True,
+- define_ret = True,
+- define = 'HAVE_BSD_STRTOLL',
+- )
+ conf.CHECK_FUNCS('if_nametoindex strerror_r')
+ conf.CHECK_FUNCS('getdirentries getdents syslog')
+ conf.CHECK_FUNCS('gai_strerror get_current_dir_name')
diff --git a/sys-libs/tdb/metadata.xml b/sys-libs/tdb/metadata.xml
new file mode 100644
index 00000000..eb993d35
--- /dev/null
+++ b/sys-libs/tdb/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>samba</herd>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-libs/tdb/tdb-1.2.11-r99.ebuild b/sys-libs/tdb/tdb-1.2.11-r99.ebuild
new file mode 100644
index 00000000..ae082f1a
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.2.11-r99.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.11.ebuild,v 1.8 2013/09/06 16:04:59 ago Exp $
+
+EAPI=3
+PYTHON_DEPEND="python? 2"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit waf-utils python
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc x86"
+IUSE="python"
+
+RDEPEND=""
+DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-remove-check-bsd-strtoll.patch
+}
+
+src_configure() {
+ local extra_opts=""
+ use python || extra_opts+=" --disable-python"
+ waf-utils_src_configure \
+ ${extra_opts}
+}
+
+src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check || die "emake check failed"
+}
diff --git a/sys-libs/tdb/tdb-1.2.12-r99.ebuild b/sys-libs/tdb/tdb-1.2.12-r99.ebuild
new file mode 100644
index 00000000..39140930
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.2.12-r99.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.12-r1.ebuild,v 1.1 2013/06/30 16:33:13 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit waf-utils python-single-r1
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-remove-check-bsd-strtoll.patch
+}
+
+src_configure() {
+ local extra_opts=""
+ use python || extra_opts+=" --disable-python"
+ waf-utils_src_configure \
+ ${extra_opts}
+}
+
+src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}