aboutsummaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDave Hughes <davidhughes205@gmail.com>2021-03-13 00:52:50 -0500
committerSam James <sam@gentoo.org>2021-03-13 21:02:39 +0000
commit23d5062088d8fec4462d398551ab8f126efec20d (patch)
tree1ad4ecb72adb2c78926bdc0f48556b2e19400111 /sys-fs
parentsys-fs/udisks: remove from overlay (diff)
downloadmusl-23d5062088d8fec4462d398551ab8f126efec20d.tar.gz
musl-23d5062088d8fec4462d398551ab8f126efec20d.tar.bz2
musl-23d5062088d8fec4462d398551ab8f126efec20d.zip
sys-fs/lvm2: sync with ::gentoo
Package-Manager: Portage-3.0.17, Repoman-3.0.2 RepoMan-Options: --force Manifest-Sign-Key: 0xA1919C830E9498E0 Signed-off-by: Dave Hughes <davidhughes205@gmail.com> Closes: https://github.com/gentoo/musl/pull/400 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lvm2/lvm2-2.02.187-r3.ebuild36
1 files changed, 26 insertions, 10 deletions
diff --git a/sys-fs/lvm2/lvm2-2.02.187-r3.ebuild b/sys-fs/lvm2/lvm2-2.02.187-r3.ebuild
index 91b6d1c5..f974d161 100644
--- a/sys-fs/lvm2/lvm2-2.02.187-r3.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.187-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,7 @@ SRC_URI="ftp://sourceware.org/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="readline static static-libs systemd lvm2create_initrd sanlock selinux +udev +thin device-mapper-only"
REQUIRED_USE="device-mapper-only? ( !lvm2create_initrd !sanlock !thin )
systemd? ( udev )"
@@ -36,12 +36,9 @@ RDEPEND="${DEPEND_COMMON}
lvm2create_initrd? ( sys-apps/makedev )
thin? ( >=sys-block/thin-provisioning-tools-0.3.0 )"
# note: thin- 0.3.0 is required to avoid --disable-thin_check_needs_check
-# USE 'static' currently only works with eudev, bug 520450
DEPEND="${DEPEND_COMMON}
- >=sys-devel/binutils-2.20.1-r1
static? (
selinux? ( sys-libs/libselinux[static-libs] )
- udev? ( >=sys-fs/eudev-3.1.2[static-libs] )
>=sys-apps/util-linux-2.16[static-libs]
)"
BDEPEND="
@@ -271,11 +268,30 @@ src_install() {
}
pkg_postinst() {
- ewarn "Make sure the \"lvm\" init script is in the runlevels:"
- ewarn "# rc-update add lvm boot"
- ewarn
- ewarn "Make sure to enable lvmetad in /etc/lvm/lvm.conf if you want"
- ewarn "to enable lvm autoactivation and metadata caching."
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ ewarn "Make sure the \"lvm\" init script is in the runlevels:"
+ ewarn "# rc-update add lvm boot"
+ ewarn
+ ewarn "Make sure to enable lvmetad in /etc/lvm/lvm.conf if you want"
+ ewarn "to enable lvm autoactivation and metadata caching."
+ fi
+
+ if use udev && [[ -d /run ]] ; then
+ local permission_run_expected="drwxr-xr-x"
+ local permission_run=$(stat -c "%A" /run)
+ if [[ "${permission_run}" != "${permission_run_expected}" ]] ; then
+ ewarn "Found the following problematic permissions:"
+ ewarn ""
+ ewarn " ${permission_run} /run"
+ ewarn ""
+ ewarn "Expected:"
+ ewarn ""
+ ewarn " ${permission_run_expected} /run"
+ ewarn ""
+ ewarn "This is known to be causing problems for UDEV-enabled LVM services."
+ fi
+ fi
}
src_test() {