aboutsummaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAlfred Persson Forsberg <cat@catcream.org>2022-07-25 22:13:16 +0200
committerAnthony G. Basile <blueness@gentoo.org>2022-07-26 12:08:21 -0400
commit0db57c9c51ad559648e3db5e85675cb2edc6f822 (patch)
tree7a4bbae579759afadb6a6036c1ecfcfd67a8d955 /dev-qt
parentdev-qt/qtwebengine: Remove unused patch (diff)
downloadmusl-0db57c9c51ad559648e3db5e85675cb2edc6f822.tar.gz
musl-0db57c9c51ad559648e3db5e85675cb2edc6f822.tar.bz2
musl-0db57c9c51ad559648e3db5e85675cb2edc6f822.zip
dev-qt/qtwebengine: Conditionally apply canonic...
This patch conditionally applies the CANONICALIZE_FILENAME patch. Generally it's a bad idea but in this case it's just an alternative to fixing this in the build system. Done because of the CMake switch in Qt6. Signed-off-by: Alfred Persson Forsberg <cat@catcream.org> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.15.5_p20220618.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-qt/qtwebengine/qtwebengine-5.15.5_p20220618.ebuild b/dev-qt/qtwebengine/qtwebengine-5.15.5_p20220618.ebuild
index ebdc15b3..1585df1a 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.15.5_p20220618.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.15.5_p20220618.ebuild
@@ -117,7 +117,6 @@ PATCHES=(
# for musl libc
"${FILESDIR}"/${PN}-5.15.5_p20220618-qmake-remove-glibc-check.patch
"${FILESDIR}"/${PN}-5.15.5_p20220618-fix-sys-queue.h.patch
- "${FILESDIR}"/${PN}-5.15.5_p20220618-musl-canonicalize-filename.patch
"${FILESDIR}"/${PN}-5.15.5_p20220618-musl-mallinfo.patch
"${FILESDIR}"/${PN}-5.15.5_p20220618-musl-mojo-strncpy.patch
"${FILESDIR}"/${PN}-5.15.5_p20220618-musl-resolv-compat.patch
@@ -182,6 +181,10 @@ src_unpack() {
}
src_prepare() {
+ # Using a conditional patch here since QMake is deprecated
+ # by CMake in Qt6. A build system change would be prettier but
+ # this works just as well right now.
+ use elibc_musl && PATCHES+=( "${FILESDIR}"/${PN}-5.15.5_p20220618-musl-canonicalize-filename.patch )
if [[ ${PV} == ${QT5_PV}_p* ]]; then
# This is made from git, and for some reason will fail w/o .git directories.
mkdir -p .git src/3rdparty/chromium/.git || die