summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJohn Robeson <johnny@localmomentum.net>2008-09-05 03:46:07 -0400
committerJohn Robeson <johnny@localmomentum.net>2008-09-05 03:46:07 -0400
commitd278915414de7478d24cda1b1ddd9bdcdf58ed62 (patch)
tree845ad03ab104837119a155b1008fb5df7e67b159 /sys-fs
parentchanging bzr location to point to upstream (diff)
downloadltsp-d278915414de7478d24cda1b1ddd9bdcdf58ed62.tar.gz
ltsp-d278915414de7478d24cda1b1ddd9bdcdf58ed62.tar.bz2
ltsp-d278915414de7478d24cda1b1ddd9bdcdf58ed62.zip
add sshfs-fuse, since it hasn't been bumped to 2.1 in portage yet
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/sshfs-fuse/Manifest2
-rw-r--r--sys-fs/sshfs-fuse/sshfs-fuse-2.1.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/sys-fs/sshfs-fuse/Manifest b/sys-fs/sshfs-fuse/Manifest
new file mode 100644
index 0000000..c0ac834
--- /dev/null
+++ b/sys-fs/sshfs-fuse/Manifest
@@ -0,0 +1,2 @@
+DIST sshfs-fuse-2.1.tar.gz 115228 RMD160 507ada336b883938a8d933502318770ad93d32e5 SHA1 c4e38fa8d4cec89af09cccae08a9f1bd96f452d4 SHA256 1234fae4686f41b343e9785b4de16dae4049ab1b4d8ba28e8479eccc1bc2d233
+EBUILD sshfs-fuse-2.1.ebuild 697 RMD160 029e982e3d8dbd0c7e5bc07e615cdb9e028433ee SHA1 71a2833e23594daf1cc8387236c7d6e7cc319374 SHA256 7e24ece28e57265ffe9ef1f028aa3930094a992e3aa68e3e57f62e53d35fc4ae
diff --git a/sys-fs/sshfs-fuse/sshfs-fuse-2.1.ebuild b/sys-fs/sshfs-fuse/sshfs-fuse-2.1.ebuild
new file mode 100644
index 0000000..e1defae
--- /dev/null
+++ b/sys-fs/sshfs-fuse/sshfs-fuse-2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/sshfs-fuse/sshfs-fuse-1.9.ebuild,v 1.6 2008/03/16 14:28:48 fmccor Exp $
+
+inherit eutils
+
+DESCRIPTION="Fuse-filesystem utilizing the sftp service."
+SRC_URI="mirror://sourceforge/fuse/${P}.tar.gz"
+HOMEPAGE="http://fuse.sourceforge.net/sshfs.html"
+LICENSE="GPL-2"
+DEPEND=">=sys-fs/fuse-2.6.0_pre3
+ >=dev-libs/glib-2.4.2"
+RDEPEND="${DEPEND}
+ >=net-misc/openssh-5.1"
+KEYWORDS="amd64 ~hppa ppc ppc64 sparc x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README NEWS ChangeLog AUTHORS
+}