summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/stumpwm/stumpwm-1.0.0.ebuild')
-rw-r--r--x11-wm/stumpwm/stumpwm-1.0.0.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/x11-wm/stumpwm/stumpwm-1.0.0.ebuild b/x11-wm/stumpwm/stumpwm-1.0.0.ebuild
index 3231eff7..7638a3b5 100644
--- a/x11-wm/stumpwm/stumpwm-1.0.0.ebuild
+++ b/x11-wm/stumpwm/stumpwm-1.0.0.ebuild
@@ -40,7 +40,7 @@ get_lisp() {
done
}
-do_doc() {
+install_docs() {
local pdffile="${PN}.pdf"
texi2pdf -o "${pdffile}" "${PN}.texi" && dodoc "${pdffile}" || die
@@ -52,10 +52,8 @@ do_doc() {
src_prepare() {
default
- # Upstream didn't change the version before packaging
- sed -i -e 's/:version "0.9.8"/:version "0.9.9"/' "${PN}.asd" || die
- # Bug 534592. Does not build with asdf:oos, using require to load the package
- sed -i "load-${PN}.lisp.in" -e "s/asdf:oos 'asdf:load-op/require/" || die
+ ## Bug 534592. Does not build with asdf:oos, using require to load the package
+ #sed -i "load-${PN}.lisp.in" -e "s/asdf:oos 'asdf:load-op/require/" || die
eautoreconf
}
@@ -74,11 +72,11 @@ src_install() {
make_session_desktop StumpWM /usr/bin/stumpwm
common-lisp-install-sources *.lisp
- common-lisp-install-asdf ${PN}.asd
+ common-lisp-install-asdf
# Fix ASDF dir
sed -i -e "/(:directory/c\ (:directory \"${CLPKGDIR}\")" \
"${D}${CLPKGDIR}/load-stumpwm.lisp" || die
- use doc && do_doc
+ use doc && install_docs
}
pkg_postinst() {