summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso <nimiux@gentoo.org>2014-02-21 11:19:14 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2018-03-09 22:33:40 +0100
commit973d43d8e6e3b0f3d3e482b02cc235da249d3932 (patch)
treeeaf880bd1366ba1b6f74bdbb66f61387c8a9ecbd /dev-lisp/cxml/cxml-9999.ebuild
parentdev-lisp/lisp-unit: remove comments (diff)
downloadlisp-973d43d8e6e3b0f3d3e482b02cc235da249d3932.tar.gz
lisp-973d43d8e6e3b0f3d3e482b02cc235da249d3932.tar.bz2
lisp-973d43d8e6e3b0f3d3e482b02cc235da249d3932.zip
dev-lisp/cxml: new live ebuild
Diffstat (limited to 'dev-lisp/cxml/cxml-9999.ebuild')
-rw-r--r--dev-lisp/cxml/cxml-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lisp/cxml/cxml-9999.ebuild b/dev-lisp/cxml/cxml-9999.ebuild
new file mode 100644
index 00000000..d49c62f2
--- /dev/null
+++ b/dev-lisp/cxml/cxml-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit common-lisp-3 git-2
+
+DESCRIPTION="An XML parser written in Common Lisp"
+HOMEPAGE="http://common-lisp.net/project/cxml/"
+EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
+
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="!dev-lisp/cl-${PN}
+ >=dev-lisp/closure-common-${PV}
+ dev-lisp/puri
+ dev-lisp/trivial-gray-streams"
+
+src_install() {
+ common-lisp-install-sources -t all *.dtd
+ common-lisp-install-sources {contrib,dom,klacks,test,xml,xml/sax-tests}/*.lisp
+ common-lisp-install-asdf
+
+ use doc && dodoc README OLDNEWS TIMES && (cd doc && make) && dohtml doc/*.{html,css,png}
+}