summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-04-10 17:49:46 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2018-04-10 17:49:46 +0200
commit56808a2a54bbf4e7d1c00fac956b442ed6882f75 (patch)
treee4ddf8053445284cd72ff1471173d2fed60a2286 /dev-libs
parentapp-emacs/slime: Fixes doc build (diff)
downloadlisp-56808a2a54bbf4e7d1c00fac956b442ed6882f75.tar.gz
lisp-56808a2a54bbf4e7d1c00fac956b442ed6882f75.tar.bz2
lisp-56808a2a54bbf4e7d1c00fac956b442ed6882f75.zip
dev-libs/ffcall: Bumps version to 2.1
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ffcall/Manifest2
-rw-r--r--dev-libs/ffcall/ffcall-2.1.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/ffcall/Manifest b/dev-libs/ffcall/Manifest
index e456d8bf..38446226 100644
--- a/dev-libs/ffcall/Manifest
+++ b/dev-libs/ffcall/Manifest
@@ -1,2 +1,4 @@
DIST libffcall-2.0.tar.gz 938605 BLAKE2B 1e6fcae8f1dcaad52ca84d0dcf97f8dde5bb8153244bbb9047dbab5f6a1dade0a00f149507e6bb14225369a7081cadb069d23c8bc7cdcfaec937d7b9d47d08c1 SHA512 d75aa1df97b14692a9137745bae5b24c4d8f739cb1c7f854e7ed47e4a77a49759122abd6b0e445efa56381f47932c13cd21a154b2783649afb9c7a39e73fea04
+DIST libffcall-2.1.tar.gz 943235 BLAKE2B ae82663174db084e830b6ff77ceedf8641b3edeb7800952ac4e2772d9033da3e45f46159e6fdae86615dc69fceba39f48d6c75e6cbd41be98f1986fa69d50b3b SHA512 da73375fb45b7d764c06437a517c2a90abf7d5de6afe0a8ca19e6dfafd2a8c7107e39d230ecbc8edfdd5926b16a0c13b7bb9319287047c47de1241b2f6ae805e
EBUILD ffcall-2.0.ebuild 1492 BLAKE2B 22911d433b8f26ffa3b1f2933df807316bfb5f140acb1acef28ac3a4f6bfdbb70d3bbe33233cdd4d4e064068ee9ef1d9ccdd3d44f2c5bcf24090de095b2e0d16 SHA512 3e39c946ebde355450fcb121296cc2bb513a6a4bac44121ddcb9eac80fdffd60cf583e48e5ed3512a7cdbcd85b47c011e9a08e20dcff6dd6d78432d247781f41
+EBUILD ffcall-2.1.ebuild 1523 BLAKE2B dd4e60e71b5b812f6a818d3acce35d0f4490994113c0d4ed7165512fc8213105b710dbe5e5c212f50aabf17e07576d6fe37f8a9d137707bdf927fd4ce762cfa7 SHA512 34a9f2ab5a6b508119c657175ea64cdeb1c90e1c2b36e4ac10ec9ab7778b231bf724c14e568f70b95c3ae0c26b0fecc1f8944644d27f005f4e7545fb9e437398
diff --git a/dev-libs/ffcall/ffcall-2.1.ebuild b/dev-libs/ffcall/ffcall-2.1.ebuild
new file mode 100644
index 00000000..b4762103
--- /dev/null
+++ b/dev-libs/ffcall/ffcall-2.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_PV="libffcall-${PV}"
+
+DESCRIPTION="Build foreign function call interfaces in embedded interpreter"
+HOMEPAGE="https://www.gnu.org/software/libffcall/"
+SRC_URI="mirror://gnu/libffcall/${MY_PV}.tar.gz"
+
+# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
+# or in derivate works of GNUstep, the included parts of ffcall are
+# under GNU LGPL." -ffcall author
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+S=${WORKDIR}/${MY_PV}
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ # The build system is a strange mix of autogenerated
+ # files and manual tweaks on top. Uses $CFLAGS / $LDFLAGS randomly.
+ # We are adding them consistently here and a bit over the top:
+ # bugs: #334581
+
+ for mfi in {,*/,*/*/,}Makefile.in
+ do
+ elog "Patching '${mfi}'"
+ # usually uses only assembler here, but -march=
+ # and -Wa, are a must to pass here.
+ sed -e 's/$(CC) /&$(CFLAGS) /g' \
+ -i "${mfi}" || die
+ done
+ eapply_user
+}
+
+src_configure() {
+ append-flags -fPIC
+
+ # Doc goes in datadir
+ econf \
+ --datadir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-shared \
+ --disable-static
+}
+
+src_compile() {
+ # TODO. Remove -j1
+ emake -j1
+}
+
+src_install() {
+ dodoc NEWS README
+ dodir /usr/share/man
+ default
+ prune_libtool_files
+}