aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog5
-rw-r--r--libvirt.spec.in9
-rw-r--r--qemud/Makefile.am2
3 files changed, 13 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 9eacb2416..137e9ab21 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+Wed Feb 14 19:53:33 CET 2007 Daniel Veillard <veillard@redhat.com>
+
+ * libvirt.spec.in: spec cleanup and missing BuildRequires
+ * qemud/Makefile.am: avoid -Werror
+
Wed Feb 14 19:06:26 CET 2007 Daniel Veillard <veillard@redhat.com>
* configure.in NEWS include/libvirt/libvirt.h docs/* docs/apibuild.py:
diff --git a/libvirt.spec.in b/libvirt.spec.in
index 2b6c4202f..672ed8fed 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -3,7 +3,7 @@
Summary: Library providing an API to use the Xen virtualization
Name: libvirt
Version: @VERSION@
-Release: 1
+Release: 1%{?dist}
License: LGPL
Group: Development/Libraries
Source: libvirt-%{version}.tar.gz
@@ -20,6 +20,7 @@ BuildRequires: readline-devel
BuildRequires: ncurses-devel
BuildRequires: gettext
BuildRequires: libsysfs-devel
+BuildRequires: gnutls-devel
Obsoletes: libvir
ExclusiveArch: i386 x86_64 ia64
@@ -43,7 +44,6 @@ Summary: Python bindings for the libvirt library
Group: Development/Libraries
Requires: libvirt = %{version}
Obsoletes: libvir-python
-Requires: %{_libdir}/python%(echo `python -c "import sys; print sys.version[0:3]"`)
%description python
The libvirt-python package contains a module that permits applications
@@ -119,6 +119,11 @@ rm -fr %{buildroot}
%doc docs/examples/python
%changelog
+* Wed Feb 14 2007 Daniel Veillard <veillard@redhat.com> 0.2.0-1
+- support for KVM and QEmu
+- support for network configuration
+- assorted fixes
+
* Wed Dec 20 2006 Daniel Veillard <veillard@redhat.com> 0.1.11-1
- finish inactive Xen domains support
- memory leak fix
diff --git a/qemud/Makefile.am b/qemud/Makefile.am
index 1bc733d7a..7c21ab7e3 100644
--- a/qemud/Makefile.am
+++ b/qemud/Makefile.am
@@ -13,7 +13,7 @@ libvirt_qemud_SOURCES = qemud.c internal.h protocol.h \
#-D_XOPEN_SOURCE=600 -D_XOPEN_SOURCE_EXTENDED=1 -D_POSIX_C_SOURCE=199506L
libvirt_qemud_CFLAGS = \
-I$(top_srcdir)/include -I$(top_builddir)/include $(LIBXML_CFLAGS) \
- -Werror -Wall -Wextra -DLOCAL_STATE_DIR="\"$(localstatedir)\"" \
+ -Wall -Wextra -DLOCAL_STATE_DIR="\"$(localstatedir)\"" \
-DSYSCONF_DIR="\"$(sysconfdir)\""
libvirt_qemud_LDFLAGS = $(LIBXML_LIBS) $(SYSFS_LIBS)
libvirt_qemud_DEPENDENCIES =