aboutsummaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorMu Qiao <qiaomuf@gentoo.org>2011-04-21 16:34:13 +0800
committerMu Qiao <qiaomuf@gentoo.org>2011-04-22 08:38:13 +0800
commitf00e6f72d20808accabb22cf49c5489f118b7bc5 (patch)
tree164f845550a9532760c1e02d92fecfda9b25cf7a /test
parentParser: turn on memoize (diff)
downloadlibbash-f00e6f72d20808accabb22cf49c5489f118b7bc5.tar.gz
libbash-f00e6f72d20808accabb22cf49c5489f118b7bc5.tar.bz2
libbash-f00e6f72d20808accabb22cf49c5489f118b7bc5.zip
Test: rename *ebuild* to *bash*
The suffix is not proper when we want to distinguish normal shell scripts from ebuilds. So we rename these tests to make it possible to use metadata_generator as the compiler for *.ebuild.
Diffstat (limited to 'test')
-rwxr-xr-xtest/verify_bashs_test.sh5
-rwxr-xr-xtest/verify_ebuilds_test.sh5
2 files changed, 5 insertions, 5 deletions
diff --git a/test/verify_bashs_test.sh b/test/verify_bashs_test.sh
new file mode 100755
index 0000000..2c42195
--- /dev/null
+++ b/test/verify_bashs_test.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+num_of_ebuild_files=$(grep 'scripts/.*.bash' $srcdir/Makefile.am | wc -l)
+[[ $num_of_ebuild_files == $(ls $srcdir/scripts/*.bash* | wc -l) ]]
+exit $?
diff --git a/test/verify_ebuilds_test.sh b/test/verify_ebuilds_test.sh
deleted file mode 100755
index 8aa84d6..0000000
--- a/test/verify_ebuilds_test.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-num_of_ebuild_files=$(grep 'scripts/.*.ebuild' $srcdir/Makefile.am | wc -l)
-[[ $num_of_ebuild_files == $(ls $srcdir/scripts/*.ebuild* | wc -l) ]]
-exit $?