aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-05 20:48:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-05 22:03:10 +0100
commit261c3a53a0d9131f592bbbb8a321bbd3f93ca44e (patch)
tree48157a3142738e2a83c1dfb3c457aa61e9710834 /www-client
parentkde-apps/konqueror: 24.08.3 version bump (diff)
downloadkde-261c3a53a0d9131f592bbbb8a321bbd3f93ca44e.tar.gz
kde-261c3a53a0d9131f592bbbb8a321bbd3f93ca44e.tar.bz2
kde-261c3a53a0d9131f592bbbb8a321bbd3f93ca44e.zip
www-client/falkon: 24.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/falkon/Manifest1
-rw-r--r--www-client/falkon/falkon-24.08.3.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/www-client/falkon/Manifest b/www-client/falkon/Manifest
new file mode 100644
index 0000000000..64f28a7646
--- /dev/null
+++ b/www-client/falkon/Manifest
@@ -0,0 +1 @@
+DIST falkon-24.08.3.tar.xz 2635964 BLAKE2B 07417017ee93f598749048d331827904d2cb7406ee9bac5da77bddc720e7c3131f655b6cb6ef35a84db73e62a11f435d347841047371590d4a889e44946a2706 SHA512 1c6020d805668de38be95f9d63a07c5b6eafb200b6b181d59c791a145ffb8926c5ecf5feb9f46c5d69deb682692574b8a557271d08f945cf1a52c1eee7b2d55b
diff --git a/www-client/falkon/falkon-24.08.3.ebuild b/www-client/falkon/falkon-24.08.3.ebuild
new file mode 100644
index 0000000000..4322d900bd
--- /dev/null
+++ b/www-client/falkon/falkon-24.08.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=6.5.0
+QTMIN=6.7.2
+PYTHON_COMPAT=( python3_{10..12} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Cross-platform web browser using QtWebEngine"
+HOMEPAGE="https://www.falkon.org/ https://apps.kde.org/falkon/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="dbus kde python +X"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test" # bug 653046
+
+COMMON_DEPEND="
+ dev-libs/openssl:0=
+ >=dev-qt/qt5compat-${QTMIN}:6
+ >=dev-qt/qtbase-${QTMIN}:6[dbus?,gui,network,sql,sqlite,ssl,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6[widgets]
+ >=dev-qt/qtwebchannel-${QTMIN}:6
+ >=dev-qt/qtwebengine-${QTMIN}:6=[widgets]
+ >=kde-frameworks/karchive-${KFMIN}:6
+ virtual/libintl
+ kde? (
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/purpose-${KFMIN}:6
+ )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep "
+ >=dev-python/pyside6-${QTMIN}[designer,gui,positioning,webengine,widgets,\${PYTHON_USEDEP}] \
+ >=dev-python/shiboken6-${QTMIN}[\${PYTHON_USEDEP}]
+ ")
+ )
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent]
+"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ DEPEND+=" >=kde-frameworks/ki18n-${KFMIN}:6"
+fi
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtsvg-${QTMIN}:6
+"
+BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ ecm_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_KEYRING=OFF
+ -DDISABLE_DBUS=$(usex !dbus)
+ $(cmake_use_find_package kde KF6Wallet)
+ $(cmake_use_find_package kde KF6KIO)
+ -DBUILD_PYTHON_SUPPORT=$(usex python)
+ -DNO_X11=$(usex !X)
+ )
+ use python && mycmakeargs+=(
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}" # shiboken_helpers.cmake quirk
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
+ ecm_src_configure
+}