aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-08-18 15:10:42 +0200
committerManuel Rüger <mrueg@gentoo.org>2013-08-18 15:10:42 +0200
commit788de3f2c9018ca8e59f9ceb436d70184897aafa (patch)
tree48730d8f197d5d69009d3be8ede73a47e81a68ce /media-sound
parent[kde-base/kdm] Adhere to coding conventions (diff)
downloadkde-788de3f2c9018ca8e59f9ceb436d70184897aafa.tar.gz
kde-788de3f2c9018ca8e59f9ceb436d70184897aafa.tar.bz2
kde-788de3f2c9018ca8e59f9ceb436d70184897aafa.zip
[media-sound/amarok] Moved to tree
Package-Manager: portage-2.2.0
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/Manifest1
-rw-r--r--media-sound/amarok/amarok-2.8.0.ebuild130
2 files changed, 0 insertions, 131 deletions
diff --git a/media-sound/amarok/Manifest b/media-sound/amarok/Manifest
deleted file mode 100644
index 5ab676dd77..0000000000
--- a/media-sound/amarok/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST amarok-2.8.0.tar.bz2 39950028 SHA256 f4b89b28f217a6d947e55fb0890de22fad8c404794c6beeb2dcaf2711b4f8ec6 SHA512 09f7f675f1223d36fb9df2f8c88923c6616524e022ad83b12bcb770dfbf60cb6b191e4035633f2ea2eee5fb7b38e6d5092cf69fe222ef9c3f3c46ba8f157a62d WHIRLPOOL 108cfd95d65e74f28f85a846f605bc349e5b2962b7f9a357415225f3e48ff87148d7f50a642665cc3c809bb2cb4c22f339ad049cdeb4659bb7c0a48e798833ad
diff --git a/media-sound/amarok/amarok-2.8.0.ebuild b/media-sound/amarok/amarok-2.8.0.ebuild
deleted file mode 100644
index add0717c7b..0000000000
--- a/media-sound/amarok/amarok-2.8.0.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-KDE_LINGUAS="bs ca ca@valencia cs da de el en_GB es et eu fi fr ga gl hu it
-ja lt lv nb nl pl pt pt_BR ro ru sl sr sr@ijekavian sr@ijekavianlatin
-sr@latin sv tr uk zh_CN zh_TW"
-KDE_REQUIRED="never"
-KDE_HANDBOOK="optional"
-VIRTUALX_REQUIRED="test"
-inherit flag-o-matic kde4-base
-
-DESCRIPTION="Advanced audio player based on KDE framework."
-HOMEPAGE="http://amarok.kde.org/"
-if [[ ${PV} != *9999* ]]; then
- if [[ $PV == *[6-9][0-9]* ]]; then
- SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
- else
- SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
- fi
- KEYWORDS="~amd64 ~ppc ~x86"
-else
- KEYWORDS=""
-fi
-
-LICENSE="GPL-2"
-SLOT="4"
-IUSE="cdda debug +embedded ipod lastfm mp3tunes mtp ofa opengl test +utils"
-
-if [[ ${PV} == *9999* ]]; then
- RESTRICT="test"
-fi
-
-# ipod requires gdk enabled and also gtk compiled in libgpod
-COMMONDEPEND="
- app-crypt/qca:2
- >=app-misc/strigi-0.5.7
- $(add_kdebase_dep kdelibs 'opengl?,semantic-desktop(+)' 4.8.4)
- $(add_kdebase_dep kdebase-kioslaves)
- >=media-libs/taglib-1.7[asf,mp4]
- >=media-libs/taglib-extras-1.0.1
- $(add_kdebase_dep nepomuk-core '' 4.9.0)
- sys-libs/zlib
- >=virtual/mysql-5.1[embedded?]
- >=dev-qt/qtcore-4.8:4
- >=dev-qt/qtdbus-4.8:4
- >=dev-qt/qtscript-4.8:4
- >=x11-libs/qtscriptgenerator-0.1.0
- cdda? (
- $(add_kdebase_dep libkcddb)
- $(add_kdebase_dep libkcompactdisc)
- $(add_kdebase_dep audiocd-kio)
- )
- ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
- lastfm? ( >=media-libs/liblastfm-1.0.3 )
- mp3tunes? (
- dev-libs/glib:2
- dev-libs/libxml2
- dev-libs/openssl
- net-libs/loudmouth
- net-misc/curl
- >=dev-qt/qtcore-4.8.4:4[glib]
- )
- mtp? ( >=media-libs/libmtp-1.0.0 )
- ofa? ( >=media-libs/libofa-0.9.0 )
- opengl? ( virtual/opengl )
-"
-DEPEND="${COMMONDEPEND}
- dev-util/automoc
- virtual/pkgconfig
- test? ( dev-cpp/gmock )
-"
-RDEPEND="${COMMONDEPEND}
- !media-sound/amarok-utils
- $(add_kdebase_dep phonon-kde)
-"
-
-src_prepare() {
- mv doc/en_US doc/en || die
- sed -e "s/en_US/en/" -i doc/CMakeLists.txt || die
-
- kde4-base_src_prepare
-}
-
-src_configure() {
- # Append minimal-toc cflag for ppc64, see bug 280552 and 292707
- use ppc64 && append-flags -mminimal-toc
- local mycmakeargs
-
- mycmakeargs=(
- -DWITH_PLAYER=ON
- -DWITH_Libgcrypt=OFF
- -DWITH_SPECTRUM_ANALYZER=OFF
- $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
- $(cmake-utils_use_with ipod)
- $(cmake-utils_use_with ipod Gdk)
- $(cmake-utils_use_with lastfm LibLastFm)
- $(cmake-utils_use_with mtp)
- $(cmake-utils_use_with mp3tunes MP3Tunes)
- $(cmake-utils_use_with ofa LibOFA)
- )
-
- mycmakeargs+=(
- $(cmake-utils_use_with utils UTILITIES)
- )
-
- kde4-base_src_configure
-}
-
-pkg_postinst() {
- kde4-base_pkg_postinst
-
- if ! use embedded; then
- echo
- elog "You've disabled the amarok support for embedded mysql DBs."
- elog "You'll have to configure amarok to use an external db server."
- echo
- elog "Please read http://amarok.kde.org/wiki/MySQL_Server for details on how"
- elog "to configure the external db and migrate your data from the embedded database."
- echo
-
- if has_version "virtual/mysql[minimal]"; then
- elog "You built mysql with the minimal use flag, so it doesn't include the server."
- elog "You won't be able to use the local mysql installation to store your amarok collection."
- echo
- fi
- fi
-}