aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-19 22:50:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-19 22:51:22 +0100
commit70e741b9b265af7dbe13c21fb91dead0997d99e8 (patch)
treee511249fcf72d010873f7a226424610fc65d8d3e /media-sound
parentmedia-libs/liblastfm: Drop Qt4 support (diff)
downloadkde-70e741b9b265af7dbe13c21fb91dead0997d99e8.tar.gz
kde-70e741b9b265af7dbe13c21fb91dead0997d99e8.tar.bz2
kde-70e741b9b265af7dbe13c21fb91dead0997d99e8.zip
media-sound/amarok: Find liblastfm header path
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/amarok-9999.ebuild5
-rw-r--r--media-sound/amarok/files/amarok-liblastfm-headers.patch25
2 files changed, 29 insertions, 1 deletions
diff --git a/media-sound/amarok/amarok-9999.ebuild b/media-sound/amarok/amarok-9999.ebuild
index 6cfbeb8ca7..863557895f 100644
--- a/media-sound/amarok/amarok-9999.ebuild
+++ b/media-sound/amarok/amarok-9999.ebuild
@@ -85,7 +85,10 @@ RDEPEND="${COMMONDEPEND}
!media-sound/amarok:4
"
-PATCHES=( ${FILESDIR}/${PN}-2.8.90-mysqld-rpath.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.8.90-mysqld-rpath.patch
+ "${FILESDIR}"/${PN}-liblastfm-headers.patch
+)
src_configure() {
local mycmakeargs=(
diff --git a/media-sound/amarok/files/amarok-liblastfm-headers.patch b/media-sound/amarok/files/amarok-liblastfm-headers.patch
new file mode 100644
index 0000000000..7120db0412
--- /dev/null
+++ b/media-sound/amarok/files/amarok-liblastfm-headers.patch
@@ -0,0 +1,25 @@
+From b331e6e7c0e34dd896e21b9d1569214a0ec0fddb Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Mon, 19 Mar 2018 22:26:54 +0100
+Subject: [PATCH] Search for liblastfm header path without suffix
+
+---
+ cmake/modules/FindLibLastFm.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/modules/FindLibLastFm.cmake b/cmake/modules/FindLibLastFm.cmake
+index a3a065f181..ef89423c90 100644
+--- a/cmake/modules/FindLibLastFm.cmake
++++ b/cmake/modules/FindLibLastFm.cmake
+@@ -13,7 +13,7 @@ find_path(LIBLASTFM_INCLUDE_DIR NAMES global.h
+ /opt/local/include
+ /usr/include
+ /usr/local/include
+- PATH_SUFFIXES lastfm5
++ PATH_SUFFIXES lastfm5 lastfm
+ )
+
+ find_library( LIBLASTFM_LIBRARY NAMES lastfm5
+--
+2.16.2
+