aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-12 12:05:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-12 12:05:01 +0200
commitb4fd4f708e13dc62d734a6a176e076a6845751c6 (patch)
tree26c58f85a5abb1e439042cf42a4154f7ecf75fbf /kde-apps/print-manager
parentkde5.eclass: Mark KDE Applications 19.04.0 unreleased (diff)
downloadkde-b4fd4f708e13dc62d734a6a176e076a6845751c6.tar.gz
kde-b4fd4f708e13dc62d734a6a176e076a6845751c6.tar.bz2
kde-b4fd4f708e13dc62d734a6a176e076a6845751c6.zip
kde-apps: Add KDE Applications 19.04.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/print-manager')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-19.04.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index 36f2f19e8f..da2d079034 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1 +1,2 @@
DIST print-manager-19.03.90.tar.xz 239736 BLAKE2B f06aa83be0f96ac3a32e9c969f1c40b5092944fb96d99b94f1bdeb9058d7c642a2bf6be40d5a08d3e2c66aee0f04bb2d4b0da0b237c00f79151a588f5e51f241 SHA512 02e5abf3101dc1e130d2c060a73e1939f651d098107aaf72b906be99151392b6a6783c8eb3ee7ccb34e7720ae4e9306edccf4d09f30e27092c75e49c62554f57
+DIST print-manager-19.04.0.tar.xz 239680 BLAKE2B 24279965099fdc2ef8f0bd99ee89f7fa67088e04f1374b63eed48453f9696884ba4bd9b45a87676b9249fe025b42805ce84e94248f217ec601e55ba3004d53b6 SHA512 3b155b507f44049c1049e66426d9ddcfa6e7c80e9ad37b328d3785d175c4bc0949d5a5d66e6c7750322b46da88dc1b68bacbaf356757697dc4e50b385e4fcf45
diff --git a/kde-apps/print-manager/print-manager-19.04.0.ebuild b/kde-apps/print-manager/print-manager-19.04.0.ebuild
new file mode 100644
index 0000000000..1ae6656076
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-19.04.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}