aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-10-08 23:50:49 -0400
committerChris Reffett <creffett@gentoo.org>2013-10-08 23:50:49 -0400
commit0888ef0e5b21ad0adf56678604304ff000c5bd19 (patch)
treee73bbd29e27ffb86812b2cff7a876a0e3d968f5d /Documentation
parent[plasma-active/plasma-mobile] Remove libkworkspace blocker, this isn't the ri... (diff)
downloadkde-0888ef0e5b21ad0adf56678604304ff000c5bd19.tar.gz
kde-0888ef0e5b21ad0adf56678604304ff000c5bd19.tar.bz2
kde-0888ef0e5b21ad0adf56678604304ff000c5bd19.zip
[bump_new_revision.sh] Make script properly handle revbumped packages in
overlay
Diffstat (limited to 'Documentation')
-rwxr-xr-xDocumentation/maintainers/bump_new_revision.sh3
1 files changed, 2 insertions, 1 deletions
diff --git a/Documentation/maintainers/bump_new_revision.sh b/Documentation/maintainers/bump_new_revision.sh
index 18b9ea0fe1..0c8bb160c8 100755
--- a/Documentation/maintainers/bump_new_revision.sh
+++ b/Documentation/maintainers/bump_new_revision.sh
@@ -361,7 +361,8 @@ case ${OPERATION} in
# we need to copy the file we want to play with
## first generate the correct filename, we expect that if someone added -rX to the package it has reason.
pushd "${OVERLAY}/${dir}" &> /dev/null
- EBUILD=`find ./ -name \*.ebuild |grep "${VERSION}\\." | sort |tail -n 1`
+ EBUILD=`find ./ -name \*.ebuild | grep "${VERSION}\(\-r[0-9]\+\)\?\\." | sort |tail -n 1`
+ echo ${EBUILD}
cp -f ${EBUILD} "${WRKDIR}"
popd &> /dev/null
_addcvsfile "${WRKDIR}" ${EBUILD/*\//}