aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-09-14 21:40:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-09-14 23:29:37 +0200
commit02f3b358202d0068793d78e142a78554b9610109 (patch)
treea78e9448fa6832217af4e450d5d664b837a6983e
parentkde-plasma/ksystemstats: 6.2.49.9999 version bump (diff)
downloadkde-02f3b358202d0068793d78e142a78554b9610109.tar.gz
kde-02f3b358202d0068793d78e142a78554b9610109.tar.bz2
kde-02f3b358202d0068793d78e142a78554b9610109.zip
kde-plasma/kwallet-pam: 6.2.49.9999 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-6.2.49.9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-6.2.49.9999.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-6.2.49.9999.ebuild
new file mode 100644
index 0000000000..2734bc8265
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-6.2.49.9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.6.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="6"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:6."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}