summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/qtorrent/qtorrent-0.9.6.1-r2.ebuild')
-rw-r--r--net-p2p/qtorrent/qtorrent-0.9.6.1-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-p2p/qtorrent/qtorrent-0.9.6.1-r2.ebuild b/net-p2p/qtorrent/qtorrent-0.9.6.1-r2.ebuild
new file mode 100644
index 00000000..3e11e31c
--- /dev/null
+++ b/net-p2p/qtorrent/qtorrent-0.9.6.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qtorrent/qtorrent-0.9.6.1-r2.ebuild,v 1.4 2007/04/12 23:01:27 opfer Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="QTorrent is a PyQt GUI for BitTorrent."
+HOMEPAGE="http://thegraveyard.org/qtorrent.php"
+SRC_URI="http://thegraveyard.org/files/${P}.tar.bz2
+ mirror://gentoo/${P}-sizetype.patch"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE=""
+DEPEND="dev-python/PyQt"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${DISTDIR}/${P}-sizetype.patch
+
+ # see bug #118234
+ sed -e 's/getOpenFileName(None,/getOpenFileName("",/' \
+ -i pyqtorrent/torrentmain.py
+}