summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-06 11:27:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-06 23:15:49 +0100
commitcbaaf02736cb909a0fa52e5b314c4b7964d412ab (patch)
tree608679a9b46b10cc1628bee8077f51f2aeb9886d /kde-plasma
parent*/*: Switch revdeps from sys-auth/polkit-qt:0[qt4] to sys-auth/polkit-qt:0-qt4 (diff)
downloadkde-sunset-cbaaf02736cb909a0fa52e5b314c4b7964d412ab.tar.gz
kde-sunset-cbaaf02736cb909a0fa52e5b314c4b7964d412ab.tar.bz2
kde-sunset-cbaaf02736cb909a0fa52e5b314c4b7964d412ab.zip
kde-plasma/kwin: EAPI-6 bump, drop IUSE="opengl,wayland", gles->gles2-only
- wayland is irrelevant in KDE SC4 times - drop REQUIRED_USE completely - drop unused cmake args Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kwin/kwin-4.11.22.ebuild34
-rw-r--r--kde-plasma/kwin/metadata.xml3
2 files changed, 13 insertions, 24 deletions
diff --git a/kde-plasma/kwin/kwin-4.11.22.ebuild b/kde-plasma/kwin/kwin-4.11.22.ebuild
index 3358c7b2..a481b672 100644
--- a/kde-plasma/kwin/kwin-4.11.22.ebuild
+++ b/kde-plasma/kwin/kwin-4.11.22.ebuild
@@ -1,22 +1,22 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
KMNAME="kde-workspace"
DECLARATIVE_REQUIRED="always"
OPENGL_REQUIRED="always"
-
#VIRTUALX_REQUIRED=test
-RESTRICT=test
-# test 8: kwin-TestVirtualDesktops hangs even with virtualx
-
inherit flag-o-matic kde4-meta
DESCRIPTION="KDE window manager"
HOMEPAGE+=" https://userbase.kde.org/KWin"
+
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug gles opengl wayland"
+IUSE="debug gles2-only"
+
+RESTRICT+=" test"
+# test 8: kwin-TestVirtualDesktops hangs even with virtualx
COMMONDEPEND="
kde-frameworks/kactivities:4
@@ -38,9 +38,8 @@ COMMONDEPEND="
>=x11-libs/libXrandr-1.2.1
x11-libs/libXrender
x11-libs/libXxf86vm
- opengl? ( >=media-libs/mesa-7.10 )
- gles? ( >=media-libs/mesa-7.12[egl(+),gles2] )
- wayland? ( >=media-libs/mesa-9.0[egl(+),wayland] )
+ !gles2-only? ( >=media-libs/mesa-7.10 )
+ gles2-only? ( >=media-libs/mesa-7.12[egl(+),gles2] )
"
DEPEND="${COMMONDEPEND}
x11-libs/xcb-util-renderutil
@@ -56,23 +55,16 @@ KMEXTRACTONLY="
libs/oxygen/
"
-PATCHES=(
- "${FILESDIR}/${P}-gcc6.patch"
-)
-
-# you need one of these
-REQUIRED_USE="!opengl? ( gles ) !gles? ( opengl ) wayland? ( gles )"
+PATCHES=( "${FILESDIR}/${P}-gcc6.patch" )
src_configure() {
# FIXME Remove when activity API moved away from libkworkspace
append-cppflags "-I${EPREFIX}/usr/include/kworkspace"
local mycmakeargs=(
- $(cmake-utils_use_with gles OpenGLES)
- $(cmake-utils_use gles KWIN_BUILD_WITH_OPENGLES)
- $(cmake-utils_use_with opengl OpenGL)
- $(cmake-utils_use_with wayland Wayland)
- -DWITH_X11_Xcomposite=ON
+ -DWITH_Wayland=OFF
+ -DWITH_OpenGLES=$(usex gles2-only)
+ -DWITH_OpenGL=$(usex !gles2-only)
)
kde4-meta_src_configure
diff --git a/kde-plasma/kwin/metadata.xml b/kde-plasma/kwin/metadata.xml
index 5640fb6e..7a38bb90 100644
--- a/kde-plasma/kwin/metadata.xml
+++ b/kde-plasma/kwin/metadata.xml
@@ -2,7 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
- <use>
- <flag name="gles">Enable support for GLES</flag>
- </use>
</pkgmetadata>