aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.eu>2013-01-02 03:05:01 -0800
committerDiego Elio Pettenò <flameeyes@flameeyes.eu>2013-01-02 03:05:01 -0800
commitb6c24fef8ae6f1c43579bde7174f3d1ddd0a0fa4 (patch)
treed5f44bb85bb4e95812b4ab2f1c22c5e4f4e36692 /Makefile
parentUpdate. (diff)
downloadhwids-b6c24fef8ae6f1c43579bde7174f3d1ddd0a0fa4.tar.gz
hwids-b6c24fef8ae6f1c43579bde7174f3d1ddd0a0fa4.tar.bz2
hwids-b6c24fef8ae6f1c43579bde7174f3d1ddd0a0fa4.zip
Add a new file from upstream udev.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ae0d66b..005e4aa 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,4 @@
+
ifeq "$(V)" "0"
STATUS = git status -s
Q=@
@@ -24,10 +25,11 @@ fetch:
$(Q)curl -z oui.txt -o oui.txt -R http://standards.ieee.org/develop/regauth/oui/oui.txt
$(Q)curl -z iab.txt -o iab.txt -R http://standards.ieee.org/develop/regauth/iab/iab.txt
$(Q)curl -z udev/20-acpi-vendor.hwdb -o udev/20-acpi-vendor.hwdb -R http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/20-acpi-vendor.hwdb
+ $(Q)curl -z udev/20-bluetooth-vendor-product.hwdb -o udev/20-bluetooth-vendor-product.hwdb http://cgit.freedesktop.org/systemd/systemd/tree/hwdb/20-bluetooth-vendor-product.hwdb
$(Q)curl -z udev-hwdb-update.pl -o udev-hwdb-update.pl -R http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/ids-update.pl
$(Q)$(STATUS)
-PV ?= $(shell ( awk '$$2 == "Date:" { print $$3; nextfile }' pci.ids usb.ids; git log --format=format:%ci -1 -- oui.txt hwdb/20-acpi-vendor.hwdb udev-hwdb-update.pl | cut -d ' ' -f1; ) | sort | tail -n 1 | tr -d -)
+PV ?= $(shell ( awk '$$2 == "Date:" { print $$3; nextfile }' pci.ids usb.ids; git log --format=format:%ci -1 -- oui.txt hwdb/20-acpi-vendor.hwdb udev/20-bluetooth-vendor-product.hwdb udev-hwdb-update.pl | cut -d ' ' -f1; ) | sort | tail -n 1 | tr -d -)
P = hwids-$(PV)
tag: