aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-10-03 15:43:26 -0400
committerMike Gilbert <floppym@gentoo.org>2017-10-03 16:01:43 -0400
commit9195c4e03ed12863fec68f512c74db825dfc8f2d (patch)
tree504351a3d1c9cecefc23e54d37e7fca570a03b6b /Makefile
parentUse new python script for udev database updates (diff)
downloadhwids-9195c4e03ed12863fec68f512c74db825dfc8f2d.tar.gz
hwids-9195c4e03ed12863fec68f512c74db825dfc8f2d.tar.bz2
hwids-9195c4e03ed12863fec68f512c74db825dfc8f2d.zip
Add sed to fix invalid UTF-8 character in usb.ids
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 80c3e5e..1d801ab 100644
--- a/Makefile
+++ b/Makefile
@@ -45,6 +45,9 @@ install: $(INSTALL_TARGETS-yes)
fetch:
$(Q)curl -z pci.ids -o pci.ids -R http://pci-ids.ucw.cz/v2.2/pci.ids
$(Q)curl -z usb.ids -o usb.ids -R http://www.linux-usb.org/usb.ids
+ $(Q)sed -e 's/\x20\xB4/\x20\xC2\xB4/' usb.ids > usb.ids.temp
+ $(Q)touch -r usb.ids usb.ids.temp
+ $(Q)mv usb.ids.temp usb.ids
$(Q)curl -z oui.txt -o oui.txt -R http://standards-oui.ieee.org/oui/oui.txt
$(Q)curl -z ma-medium.txt -o ma-medium.txt -R http://standards-oui.ieee.org/oui28/mam.txt
$(Q)curl -z ma-small.txt -o ma-small.txt -R http://standards-oui.ieee.org/oui36/oui36.txt