aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-05-10 14:06:38 +0200
committerJauhien Piatlicki <jauhien@gentoo.org>2014-05-10 14:06:38 +0200
commitf40edef90d380c0aa271e2177b4d81345e3a62f3 (patch)
treea128663c4730724551a811cd7fb9a72e5968c57c
parentremove gs-ctan as Gentoo already has good support for CTAN packages (diff)
downloadgs-elpa-f40edef90d380c0aa271e2177b4d81345e3a62f3.tar.gz
gs-elpa-f40edef90d380c0aa271e2177b4d81345e3a62f3.tar.bz2
gs-elpa-f40edef90d380c0aa271e2177b4d81345e3a62f3.zip
version 0.1 released
-rw-r--r--README.md86
-rw-r--r--docs/gs-elpa.82
-rw-r--r--docs/gs-elpa.8.rst2
-rw-r--r--setup.py2
4 files changed, 52 insertions, 40 deletions
diff --git a/README.md b/README.md
index 7a03840..634e566 100644
--- a/README.md
+++ b/README.md
@@ -1,54 +1,54 @@
This is [g-sorcery](https://github.com/jauhien/g-sorcery) backend for elisp packages.
-Installation and using
+Installation
======================
-Installation: in progress (use dev-portage/g-sorcery-9999, at the moment it has bundled backends).
+Currently to install gs-elpa you need to add my overlay:
-There are two ways of using **gs-elpa**:
-
-* use it with **layman**
-
-In this case all you need to do is install **layman-9999** and **g-sorcery**.
-Then you should just run `layman -L` as
-root and find an overlay you want. Type of overlay will be
-displayed as *g-sorcery*. Then you add this overlay as
-usual. It's all you need to do and it's the recommended way of
-using **g-sorcery**.
+```
+ layman -a jauhien
+```
-Using **g-sorcery** with layman you can populate overlay only with packages you want.
-To do so you should add a section named BACKEND (BACKEND here is the name of backend used for
-your repo). In this section you can add entries named REPO_packages (REPO here is the name
-of repository you want to add) which are space separated lists of packages you need. ebuilds for
-dependencies will be generated automatically if backend supports this possibility.
+In the nearest future I'll add this package to the tree so this step will be not needed.
-Note, that some overlays may depend on other overlays, in this case you'll need to add those
-dependencies first.
+Then just emerge gs-elpa:
+```
+ emerge -va gs-elpa
+```
-* use it as stand-alone tool
+Note that it uses layman-9999.
-In this case you should create an overlay (see **portage** documentation), sync it and populate
-it with one or more ebuilds. Then ebuilds could be installed by emerge or by **gs-elpa** tool.
-**Using gs-elpa with layman**
+Usage
+======================
-Execute
+There are two ways of using **gs-elpa**
-**layman -L**
+** Using gs-elpa with [layman](https://wiki.gentoo.org/wiki/Layman) **
-Find there an overlay you need (there are
-3 gs-elpa overlays currently: gnu-elpa, marmalade and melpa).
-Add, e.g.
+It the the recommend way and I strongly suggest it.
-**layman -a gnu-elpa -a marmalade**
+Then you should just run `layman -L` as
+root and find an overlay you want. Type of overlay will be
+displayed as *g-sorcery*. Then you add this overlay as
+usually and emerge packages you want. It's all you need to do. Example:
-Emerge any package from it, e.g.
+```
+ layman -L
+ layman -a gnu-elpa -a marmalade
+ emerge -va clojure-mode
+```
-**emerge -va clojure-mode**
+There are 3 gs-elpa overlays currently: [gnu-elpa](http://elpa.gnu.org/), [marmalade](http://marmalade-repo.org/)
+and [melpa](http://melpa.milkbox.net/).
-To generate only ebuilds we need such a */etc/g-sorcery/g-sorcery.cfg* file can be used:
+When using **gs-elpa** with layman you can populate overlay only with packages you want.
+To do so you should add a section named gs-elpa to */etc/g-sorcery/g-sorcery.cfg*.
+In this section you can add entries named REPO_packages (REPO here is the name
+of repository you want to add) which are space separated lists of packages you need. ebuilds for
+dependencies will be generated automatically if backend supports this possibility.
```
[main]
@@ -57,21 +57,33 @@ package_manager=portage
[gs-elpa]
marmalade_packages = clojure-mode clojurescript-mode
```
+Note, that some overlays may depend on other overlays, in this case you'll need to add those
+dependencies first (I'd recommend to always add the whole gnu-elpa overlay).
+
+** Using gs-elpa as stand-alone tool **
-**Generating user ebuilds in user overlay**
+In this case you should create an overlay (see **portage** documentation), sync it and populate
+it with one or more ebuilds. Then ebuilds could be installed by emerge or by **gs-elpa** tool.
+This is not the recommended way and may be removed in the future.
-Create new user overlay. Run
+Create new user overlay:
-**gs-elpa -o** *OVERLAY_DIRECTORY* **-r gnu-elpa** **sync**
+```
+ gs-elpa -o $OVERLAY_DIRECTORY -r gnu-elpa sync
+```
List packages:
-**gs-elpa -o** *OVERLAY_DIRECTORY* **-r gnu-elpa** **list**
+```
+ gs-elpa -o $OVERLAY_DIRECTORY -r gnu-elpa list
+```
Install any package you want:
-**gs-elpa -o** *OVERLAY_DIRECTORY* **-r gnu-elpa** **install** *PACKAGE*
+```
+ gs-elpa -o $OVERLAY_DIRECTORY -r gnu-elpa install $PACKAGE
+```
Repositories you can use are gnu-elpa, marmalade and melpa. You can use them
all in one overlay. Note, that if you call **generate-tree** command your overlay
diff --git a/docs/gs-elpa.8 b/docs/gs-elpa.8
index b5e53ef..b4614ae 100644
--- a/docs/gs-elpa.8
+++ b/docs/gs-elpa.8
@@ -53,7 +53,7 @@ There are two ways of using \fBgs\-elpa\fP:
.IP \(bu 2
use it with \fBlayman\fP
.sp
-In this case all you need to do is install \fBlayman\-9999\fP and \fBg\-sorcery\fP.
+In this case all you need to do is install \fBgs\-elpa\fP.
Then you should just run \fIlayman \-L\fP as
root and find an overlay you want. Type of overlay will be
displayed as \fIg\-sorcery\fP. Then you add this overlay as
diff --git a/docs/gs-elpa.8.rst b/docs/gs-elpa.8.rst
index 356f95b..6bc1bca 100644
--- a/docs/gs-elpa.8.rst
+++ b/docs/gs-elpa.8.rst
@@ -39,7 +39,7 @@ There are two ways of using **gs-elpa**:
* use it with **layman**
- In this case all you need to do is install **layman-9999** and **g-sorcery**.
+ In this case all you need to do is install **gs-elpa**.
Then you should just run `layman -L` as
root and find an overlay you want. Type of overlay will be
displayed as *g-sorcery*. Then you add this overlay as
diff --git a/setup.py b/setup.py
index 4cc3c11..c7aaf60 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from distutils.core import setup
setup(name = 'gs-elpa',
- version = '0.1_alpha',
+ version = '0.1',
description = 'g-sorcery backend for elisp packages',
author = 'Jauhien Piatlicki',
author_email = 'jauhien@gentoo.org',