summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-11-20 11:50:30 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-11-20 11:51:58 +0100
commitb92eb1efb6698235d4a000fb8a56254914c53089 (patch)
tree31a56c1d967cd15552dee8a72d22c85f320bc831 /gnome-extra
parentgnome-extra/gnome-color-manager: 3.30 in ::gentoo (diff)
downloadgnome-b92eb1efb6698235d4a000fb8a56254914c53089.tar.gz
gnome-b92eb1efb6698235d4a000fb8a56254914c53089.tar.bz2
gnome-b92eb1efb6698235d4a000fb8a56254914c53089.zip
gnome-extra/gnome-color-manager: sync with ::gentoo
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Manifest-Sign-Key: 0x5A56C8CD0C13248A Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-color-manager/gnome-color-manager-9999.ebuild30
1 files changed, 23 insertions, 7 deletions
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-9999.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-9999.ebuild
index 55635ddf..0c190077 100644
--- a/gnome-extra/gnome-color-manager/gnome-color-manager-9999.ebuild
+++ b/gnome-extra/gnome-color-manager/gnome-color-manager-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit git-r3 gnome-meson virtualx
+inherit git-r3 gnome.org gnome2-utils meson virtualx xdg
DESCRIPTION="Color profile manager for the GNOME desktop"
HOMEPAGE="https://git.gnome.org/browse/gnome-color-manager"
@@ -46,12 +46,22 @@ PATCHES=(
"${FILESDIR}"/9999-remove-unwanted-check.patch
)
+src_prepare() {
+ xdg_src_prepare
+
+ # Fix hard-coded package name
+ # https://gitlab.gnome.org/GNOME/gnome-color-manager/issues/3
+ sed 's:argyllcms:media-gfx/argyllcms:' src/gcm-utils.h || die
+}
+
src_configure() {
# Always enable tests since they are check_PROGRAMS anyway
- gnome-meson_src_configure \
- $(meson_use raw enable-exiv) \
- $(meson_use packagekit enable-packagekit) \
- $(meson_use test enable-tests)
+ local emesonargs=(
+ $(meson_use raw exiv)
+ $(meson_use packagekit)
+ $(meson_use test tests)
+ )
+ meson_src_configure
}
src_test() {
@@ -59,10 +69,16 @@ src_test() {
}
pkg_postinst() {
- gnome-meson_pkg_postinst
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
if ! has_version media-gfx/argyllcms ; then
elog "If you want to do display or scanner calibration, you will need to"
elog "install media-gfx/argyllcms"
fi
}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}