diff options
author | Christian Ruppert <idl0r@gentoo.org> | 2012-02-13 19:27:41 +0100 |
---|---|---|
committer | Christian Ruppert <idl0r@gentoo.org> | 2012-02-13 19:27:41 +0100 |
commit | dda7e2a3f84e6818f0c46c55f342f7e51802db5f (patch) | |
tree | b762ef6deb3f8194b708f9cbc6685018f9d016b8 /Makefile | |
parent | moved shutdown-custom script in the right dir (diff) | |
download | gentoo-vdr-scripts-dda7e2a3f84e6818f0c46c55f342f7e51802db5f.tar.gz gentoo-vdr-scripts-dda7e2a3f84e6818f0c46c55f342f7e51802db5f.tar.bz2 gentoo-vdr-scripts-dda7e2a3f84e6818f0c46c55f342f7e51802db5f.zip |
Update dist target for git
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 24 |
1 files changed, 7 insertions, 17 deletions
@@ -9,20 +9,12 @@ all: VERSION := $(shell grep '^Version' README | awk '{ print $$2 }') TMPDIR = /tmp ARCHIVE = gentoo-vdr-scripts-$(VERSION) -PACKAGE = $(ARCHIVE) - -info: - @echo VERSION: $(VERSION) - @[ -d ../tags/$(VERSION) ] && echo "Already tagged in svn" - @echo - @[ -d .svn ] && svn info +PACKAGE = $(ARCHIVE).tar.bz2 +GITREF ?= HEAD dist: - @-rm -rf $(TMPDIR)/$(ARCHIVE) - @svn export . $(TMPDIR)/$(ARCHIVE) - @tar cjf $(PACKAGE).tar.bz2 -C $(TMPDIR) $(ARCHIVE) - @-rm -rf $(TMPDIR)/$(ARCHIVE) - @echo Distribution package created as $(PACKAGE).tar.bz2 + @git archive --prefix=$(ARCHIVE)/ $(GITREF) | bzip2 > $(PACKAGE) + @echo Distribution package created as $(PACKAGE) install: @for DIR in $(SUBDIRS); do \ @@ -31,10 +23,8 @@ install: @install -m 0755 -o vdr -g vdr -d $(DESTDIR)/var/vdr/{shutdown-data,merged-config-files} snapshot: - svn export . gentoo-vdr-scripts-snapshot - tar cvfz gentoo-vdr-scripts-snapshot.tgz gentoo-vdr-scripts-snapshot - scp gentoo-vdr-scripts-snapshot.tgz dev.gentoo.org:public_html/distfiles/gentoo-vdr-scripts-snapshot.tgz - rm gentoo-vdr-scripts-snapshot.tgz - rm -rf gentoo-vdr-scripts-snapshot + git archive HEAD | bzip2 gentoo-vdr-scripts-snapshot.tar.bz2 + scp gentoo-vdr-scripts-snapshot.tar.bz2 dev.gentoo.org:public_html/distfiles/gentoo-vdr-scripts-snapshot.tar.bz2 + rm gentoo-vdr-scripts-snapshot.tar.bz2 .PHONY: all compile install snapshot |