summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-03-30 13:43:06 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-09 18:49:23 -0400
commite2ce2e16d38488fa19e36fb8b2cb30c9c9996d4d (patch)
tree1e8f18c7aaea9f2a0cd1d9d7100ceb455fb96e49 /app-editors/pluma/pluma-9999.ebuild
parentmedia-gfx/eom: Drop old, sync with Gentoo (diff)
downloadgentoo-mate-e2ce2e16d38488fa19e36fb8b2cb30c9c9996d4d.tar.gz
gentoo-mate-e2ce2e16d38488fa19e36fb8b2cb30c9c9996d4d.tar.bz2
gentoo-mate-e2ce2e16d38488fa19e36fb8b2cb30c9c9996d4d.zip
app-editors/pluma: Drop old, sync from Gentoo
Package-Manager: Portage-2.3.96, Repoman-2.3.21 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'app-editors/pluma/pluma-9999.ebuild')
-rw-r--r--app-editors/pluma/pluma-9999.ebuild52
1 files changed, 28 insertions, 24 deletions
diff --git a/app-editors/pluma/pluma-9999.ebuild b/app-editors/pluma/pluma-9999.ebuild
index 65d4d2f..b4b4168 100644
--- a/app-editors/pluma/pluma-9999.ebuild
+++ b/app-editors/pluma/pluma-9999.ebuild
@@ -1,23 +1,23 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MATE_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
-inherit mate multilib python-single-r1 virtualx
+inherit mate python-single-r1 virtualx
if [[ ${PV} != 9999 ]]; then
- KEYWORDS="~amd64 ~arm ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
DESCRIPTION="Pluma text editor for the MATE desktop"
-LICENSE="GPL-2"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
SLOT="0"
-IUSE="+introspection spell"
+IUSE="+introspection spell test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -25,46 +25,50 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# https://github.com/mate-desktop/mate-text-editor/issues/33
RESTRICT="test"
-COMMON_DEPEND="dev-libs/atk:0
- >=dev-libs/glib-2.36:2
+COMMON_DEPEND="dev-libs/atk
+ >=dev-libs/glib-2.50:2
>=dev-libs/libpeas-1.2.0[gtk]
>=dev-libs/libxml2-2.5:2
- x11-libs/cairo:0
+ x11-libs/cairo
x11-libs/gdk-pixbuf:2
- >=x11-libs/gtk+-3.14.0:3[introspection?]
+ >=x11-libs/gtk+-3.22:3[introspection?]
>=x11-libs/gtksourceview-3.0.0:3.0
- x11-libs/libICE:0
- x11-libs/libX11:0
+ x11-libs/libICE
+ x11-libs/libX11
>=x11-libs/libSM-1.0
- x11-libs/pango:0
- virtual/libintl:0
+ x11-libs/pango
introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
spell? (
- >=app-text/enchant-1.2:0
- >=app-text/iso-codes-0.35:0
+ >=app-text/enchant-1.6:=
+ >=app-text/iso-codes-0.35
)
- !!app-editors/mate-text-editor"
+ !!app-editors/mate-text-editor
+"
RDEPEND="${PYTHON_DEPS}
${COMMON_DEPEND}
- >=mate-base/mate-desktop-1.9[introspection?]"
+ >=mate-base/mate-desktop-1.9[introspection?]
+ virtual/libintl
+"
DEPEND="${COMMON_DEPEND}
~app-text/docbook-xml-dtd-4.1.2
- app-text/rarian:0
+ app-text/rarian
>=app-text/scrollkeeper-dtd-1:1.0
- app-text/yelp-tools:0
+ app-text/yelp-tools
+ dev-util/glib-utils
dev-util/gtk-doc
dev-util/gtk-doc-am
- >=dev-util/intltool-0.50.1:*
>=sys-devel/libtool-2.2.6:2
- >=sys-devel/gettext-0.17:*
- virtual/pkgconfig:*"
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
src_configure() {
mate_src_configure \
$(use_enable introspection) \
- $(use_enable spell)
+ $(use_enable spell) \
+ $(use_enable test tests)
}
src_test() {