aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-07-14 11:43:59 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-07-14 13:58:16 +0200
commit3d071ae86e9b3a08250382f970b2eaea0db85090 (patch)
tree08168b25ce7d0101c7d139d217cf04321c0bcfb5 /patches
parentRework --mdadm support (diff)
downloadgenkernel-3d071ae86e9b3a08250382f970b2eaea0db85090.tar.gz
genkernel-3d071ae86e9b3a08250382f970b2eaea0db85090.tar.bz2
genkernel-3d071ae86e9b3a08250382f970b2eaea0db85090.zip
Rework --luks support
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'patches')
-rw-r--r--patches/libgcrypt/1.8.4/libgcrypt-1.8.4-ac_cv_sys_symbol_underscore.patch37
-rw-r--r--patches/libgpg-error/1.36/libgpg-error-1.36-gawk5-support.patch158
-rw-r--r--patches/libgpg-error/1.36/libgpg-error-1.36-gpg-error-config.patch38
3 files changed, 233 insertions, 0 deletions
diff --git a/patches/libgcrypt/1.8.4/libgcrypt-1.8.4-ac_cv_sys_symbol_underscore.patch b/patches/libgcrypt/1.8.4/libgcrypt-1.8.4-ac_cv_sys_symbol_underscore.patch
new file mode 100644
index 0000000..d2bb5d1
--- /dev/null
+++ b/patches/libgcrypt/1.8.4/libgcrypt-1.8.4-ac_cv_sys_symbol_underscore.patch
@@ -0,0 +1,37 @@
+fix incorrect setting of $ac_cv_sys_symbol_underscore.
+There is no reason not to AC_COMPILE and use the set cross-nm to look for
+the symbol mangling scheme. Thus it is incorrect to check for cross compilation
+in the GNUPG_SYS_SYMBOL_UNDERSCORE check.
+
+Origin:
+
+aldot at uclibc.org aldot at uclibc.org
+Wed Sep 19 12:20:53 UTC 2007
+
+http://lists.uclibc.org/pipermail/buildroot/2007-September/017322.html
+
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -76,13 +76,14 @@ case "${host}" in
+ i386-emx-os2 | i[3456]86-pc-os2*emx | i386-pc-msdosdjgpp)
+ ac_cv_sys_symbol_underscore=yes
+ ;;
+- *)
+- if test "$cross_compiling" = yes; then
+- if test "x$ac_cv_sys_symbol_underscore" = x ; then
+- ac_cv_sys_symbol_underscore=yes
+- fi
+- else
+- tmp_do_check="yes"
++ *) if test -z "$ac_cv_sys_symbol_underscore"; then
++ if test "$cross_compiling" = yes; then
++ if test "x$ac_cv_sys_symbol_underscore" = x ; then
++ ac_cv_sys_symbol_underscore=yes
++ fi
++ else
++ tmp_do_check="yes"
++ fi
+ fi
+ ;;
+ esac
+
diff --git a/patches/libgpg-error/1.36/libgpg-error-1.36-gawk5-support.patch b/patches/libgpg-error/1.36/libgpg-error-1.36-gawk5-support.patch
new file mode 100644
index 0000000..17e8816
--- /dev/null
+++ b/patches/libgpg-error/1.36/libgpg-error-1.36-gawk5-support.patch
@@ -0,0 +1,158 @@
+From 7865041c77f4f7005282f10f9b6666b19072fbdf Mon Sep 17 00:00:00 2001
+From: NIIBE Yutaka <gniibe@fsij.org>
+Date: Mon, 15 Apr 2019 15:10:44 +0900
+Subject: [PATCH] awk: Prepare for Gawk 5.0.
+
+* src/Makefile.am: Use pkg_namespace (instead of namespace).
+* src/mkerrnos.awk: Likewise.
+* lang/cl/mkerrcodes.awk: Don't escape # in regexp.
+* src/mkerrcodes.awk, src/mkerrcodes1.awk, src/mkerrcodes2.awk: Ditto.
+
+--
+
+In Gawk 5.0, regexp routines are replaced by Gnulib implementation,
+which only allows escaping specific characters.
+
+GnuPG-bug-id: 4459
+Reported-by: Marius Schamschula
+Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
+---
+ lang/cl/mkerrcodes.awk | 2 +-
+ src/Makefile.am | 2 +-
+ src/mkerrcodes.awk | 2 +-
+ src/mkerrcodes1.awk | 2 +-
+ src/mkerrcodes2.awk | 2 +-
+ src/mkerrnos.awk | 2 +-
+ src/mkstrtable.awk | 10 +++++-----
+ 7 files changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/lang/cl/mkerrcodes.awk b/lang/cl/mkerrcodes.awk
+index ae29043..9a1fc18 100644
+--- a/lang/cl/mkerrcodes.awk
++++ b/lang/cl/mkerrcodes.awk
+@@ -122,7 +122,7 @@ header {
+ }
+
+ !header {
+- sub (/\#.+/, "");
++ sub (/#.+/, "");
+ sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
+
+ if (/^$/)
+diff --git a/src/Makefile.am b/src/Makefile.am
+index ce1b882..f2590cb 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -293,7 +293,7 @@ code-from-errno.h: mkerrcodes$(EXEEXT_FOR_BUILD) Makefile
+
+ errnos-sym.h: Makefile mkstrtable.awk errnos.in
+ $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=2 -v nogettext=1 \
+- -v prefix=GPG_ERR_ -v namespace=errnos_ \
++ -v prefix=GPG_ERR_ -v pkg_namespace=errnos_ \
+ $(srcdir)/errnos.in >$@
+
+
+diff --git a/src/mkerrcodes.awk b/src/mkerrcodes.awk
+index 46d436c..e9c857c 100644
+--- a/src/mkerrcodes.awk
++++ b/src/mkerrcodes.awk
+@@ -85,7 +85,7 @@ header {
+ }
+
+ !header {
+- sub (/\#.+/, "");
++ sub (/#.+/, "");
+ sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
+
+ if (/^$/)
+diff --git a/src/mkerrcodes1.awk b/src/mkerrcodes1.awk
+index a771a73..4578e29 100644
+--- a/src/mkerrcodes1.awk
++++ b/src/mkerrcodes1.awk
+@@ -81,7 +81,7 @@ header {
+ }
+
+ !header {
+- sub (/\#.+/, "");
++ sub (/#.+/, "");
+ sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
+
+ if (/^$/)
+diff --git a/src/mkerrcodes2.awk b/src/mkerrcodes2.awk
+index ea58503..188f7a4 100644
+--- a/src/mkerrcodes2.awk
++++ b/src/mkerrcodes2.awk
+@@ -91,7 +91,7 @@ header {
+ }
+
+ !header {
+- sub (/\#.+/, "");
++ sub (/#.+/, "");
+ sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
+
+ if (/^$/)
+diff --git a/src/mkerrnos.awk b/src/mkerrnos.awk
+index f79df66..15b1aad 100644
+--- a/src/mkerrnos.awk
++++ b/src/mkerrnos.awk
+@@ -83,7 +83,7 @@ header {
+ }
+
+ !header {
+- sub (/\#.+/, "");
++ sub (/#.+/, "");
+ sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
+
+ if (/^$/)
+diff --git a/src/mkstrtable.awk b/src/mkstrtable.awk
+index c9de9c1..285e45f 100644
+--- a/src/mkstrtable.awk
++++ b/src/mkstrtable.awk
+@@ -77,7 +77,7 @@
+ #
+ # The variable prefix can be used to prepend a string to each message.
+ #
+-# The variable namespace can be used to prepend a string to each
++# The variable pkg_namespace can be used to prepend a string to each
+ # variable and macro name.
+
+ BEGIN {
+@@ -102,7 +102,7 @@ header {
+ print "/* The purpose of this complex string table is to produce";
+ print " optimal code with a minimum of relocations. */";
+ print "";
+- print "static const char " namespace "msgstr[] = ";
++ print "static const char " pkg_namespace "msgstr[] = ";
+ header = 0;
+ }
+ else
+@@ -110,7 +110,7 @@ header {
+ }
+
+ !header {
+- sub (/\#.+/, "");
++ sub (/#.+/, "");
+ sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
+
+ if (/^$/)
+@@ -150,7 +150,7 @@ END {
+ else
+ print " gettext_noop (\"" last_msgstr "\");";
+ print "";
+- print "static const int " namespace "msgidx[] =";
++ print "static const int " pkg_namespace "msgidx[] =";
+ print " {";
+ for (i = 0; i < coded_msgs; i++)
+ print " " pos[i] ",";
+@@ -158,7 +158,7 @@ END {
+ print " };";
+ print "";
+ print "static GPG_ERR_INLINE int";
+- print namespace "msgidxof (int code)";
++ print pkg_namespace "msgidxof (int code)";
+ print "{";
+ print " return (0 ? 0";
+
+--
+2.21.0
+
diff --git a/patches/libgpg-error/1.36/libgpg-error-1.36-gpg-error-config.patch b/patches/libgpg-error/1.36/libgpg-error-1.36-gpg-error-config.patch
new file mode 100644
index 0000000..e94d57e
--- /dev/null
+++ b/patches/libgpg-error/1.36/libgpg-error-1.36-gpg-error-config.patch
@@ -0,0 +1,38 @@
+diff --git a/configure.ac b/configure.ac
+index e46b240..4606c31 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -531,16 +531,6 @@ fi
+ GPG_ERROR_CONFIG_HOST="$host"
+
+ case "$includedir" in
+- /usr/include|/include) ;;
+- '${prefix}/include')
+- if test "$prefix" != / -a "$prefix" != /usr; then
+- if test -z "$GPG_ERROR_CONFIG_CFLAGS"; then
+- GPG_ERROR_CONFIG_CFLAGS="-I$includedir"
+- else
+- GPG_ERROR_CONFIG_CFLAGS="-I$includedir $GPG_ERROR_CONFIG_CFLAGS"
+- fi
+- fi
+- ;;
+ *)
+ if test -z "$GPG_ERROR_CONFIG_CFLAGS"; then
+ GPG_ERROR_CONFIG_CFLAGS="-I$includedir"
+@@ -550,16 +540,6 @@ case "$includedir" in
+ ;;
+ esac
+ case "$libdir" in
+- /usr/lib|/usr/lib64|/lib|/lib64) ;;
+- '${exec_prefix}/lib')
+- if test "$exec_prefix" = "NONE"; then
+- if test "$prefix" != / -a "$prefix" != /usr; then
+- GPG_ERROR_CONFIG_LIBS="-L$libdir $GPG_ERROR_CONFIG_LIBS"
+- fi
+- elif test "$exec_prefix" != / -a "$exec_prefix" != /usr; then
+- GPG_ERROR_CONFIG_LIBS="-L$libdir $GPG_ERROR_CONFIG_LIBS"
+- fi
+- ;;
+ *) GPG_ERROR_CONFIG_LIBS="-L$libdir $GPG_ERROR_CONFIG_LIBS" ;;
+ esac
+