aboutsummaryrefslogtreecommitdiff
path: root/4.8.2
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-01-03 15:32:02 +0000
committerMike Frysinger <vapier@gentoo.org>2014-01-03 15:32:02 +0000
commit8fca73587349e01f00f661aed8a277c958320387 (patch)
tree28d1aac508a855872c85b708afb678c397539442 /4.8.2
parentre-order hunks so we modify configure.ac first and then configure ... on some... (diff)
downloadgcc-patches-8fca73587349e01f00f661aed8a277c958320387.tar.gz
gcc-patches-8fca73587349e01f00f661aed8a277c958320387.tar.bz2
gcc-patches-8fca73587349e01f00f661aed8a277c958320387.zip
do not build libbacktrace with -Werror
Diffstat (limited to '4.8.2')
-rw-r--r--4.8.2/gentoo/19_all_libbacktrace-Werror.patch61
-rw-r--r--4.8.2/gentoo/README.history3
2 files changed, 63 insertions, 1 deletions
diff --git a/4.8.2/gentoo/19_all_libbacktrace-Werror.patch b/4.8.2/gentoo/19_all_libbacktrace-Werror.patch
new file mode 100644
index 0000000..6cb26de
--- /dev/null
+++ b/4.8.2/gentoo/19_all_libbacktrace-Werror.patch
@@ -0,0 +1,61 @@
+add a --enable-werror flag
+
+2014-01-03 Mike Frysinger <dirtyepic@gentoo.org>
+
+ * configure.ac: Add --enable-werror.
+ (WARN_FLAGS): Use it.
+ * configure: Regenerate.
+
+--- a/libbacktrace/configure.ac
++++ a/libbacktrace/configure.ac
+@@ -132,8 +132,13 @@ ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wwri
+ -Wmissing-format-attribute -Wcast-qual],
+ [WARN_FLAGS])
+
++AC_ARG_ENABLE(werror, [AS_HELP_STRING([--enable-werror],
++ [turns on -Werror @<:@default=yes@:>@])])
++
+ if test -n "${with_target_subdir}"; then
+- WARN_FLAGS="$WARN_FLAGS -Werror"
++ if test "x$enable_werror" != "xno"; then
++ WARN_FLAGS="$WARN_FLAGS -Werror"
++ fi
+ fi
+
+ AC_SUBST(WARN_FLAGS)
+--- a/libbacktrace/configure
++++ a/libbacktrace/configure
+@@ -730,6 +730,7 @@ enable_fast_install
+ with_gnu_ld
+ enable_libtool_lock
+ enable_multilib
++enable_werror
+ with_system_libunwind
+ '
+ ac_precious_vars='build_alias
+@@ -1370,6 +1371,7 @@ Optional Features:
+ optimize for fast installation [default=yes]
+ --disable-libtool-lock avoid locking (might break parallel builds)
+ --enable-multilib build many library versions (default)
++ --enable-werror turns on -Werror [default=yes]
+
+ Optional Packages:
+ --with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
+@@ -11614,8 +11616,16 @@ fi
+ CFLAGS="$save_CFLAGS"
+
+
++# Check whether --enable-werror was given.
++if test "${enable_werror+set}" = set; then :
++ enableval=$enable_werror;
++fi
++
++
+ if test -n "${with_target_subdir}"; then
+- WARN_FLAGS="$WARN_FLAGS -Werror"
++ if test "x$enable_werror" != "xno"; then
++ WARN_FLAGS="$WARN_FLAGS -Werror"
++ fi
+ fi
+
+
diff --git a/4.8.2/gentoo/README.history b/4.8.2/gentoo/README.history
index a8200fd..4634449 100644
--- a/4.8.2/gentoo/README.history
+++ b/4.8.2/gentoo/README.history
@@ -1,6 +1,7 @@
-1.3 [pending]
+1.3 03 Jan 2014
U 17_all_libitm-Werror.patch
U 18_all_libatomic-Werror.patch
+ + 19_all_libbacktrace-Werror.patch
U 93_all_cross-build-cxxflags.patch
1.2 29 Dec 2013