summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <mva@mva.name>2015-01-11 18:57:40 +0600
committerVadim A. Misbakh-Soloviov <mva@mva.name>2015-01-11 18:57:40 +0600
commitc46072181666028d4c72fe307b5b8414cb716d92 (patch)
tree3157930806892bc1fed8a13f5722953043e8aecf /games-util
parent[games-arcade/dustforce] Bumped + rewritten (diff)
downloadgamerlay-c46072181666028d4c72fe307b5b8414cb716d92.tar.gz
gamerlay-c46072181666028d4c72fe307b5b8414cb716d92.tar.bz2
gamerlay-c46072181666028d4c72fe307b5b8414cb716d92.zip
[games-util/steam-launcher] some improvements from bug531990#c25
Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/steam-launcher/steam-launcher-1.0.0.47-r1.ebuild114
-rw-r--r--games-util/steam-launcher/steam-launcher-1.0.0.47.ebuild108
-rw-r--r--games-util/steam-launcher/steam-launcher-1.0.0.49.ebuild10
3 files changed, 9 insertions, 223 deletions
diff --git a/games-util/steam-launcher/steam-launcher-1.0.0.47-r1.ebuild b/games-util/steam-launcher/steam-launcher-1.0.0.47-r1.ebuild
deleted file mode 100644
index 809ea47..0000000
--- a/games-util/steam-launcher/steam-launcher-1.0.0.47-r1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-# Please report bugs/suggestions on: https://github.com/anyc/steam-overlay
-# or come to #gentoo-gamerlay in freenode IRC
-
-inherit eutils gnome2-utils fdo-mime games
-
-DESCRIPTION="Installer, launcher and supplementary files for Valve's Steam client"
-HOMEPAGE="http://steampowered.com"
-SRC_URI="http://repo.steampowered.com/steam/archive/precise/steam_${PV}.tar.gz"
-
-KEYWORDS=""
-LICENSE="ValveSteamLicense"
-
-RESTRICT="bindist mirror"
-SLOT="0"
-
-RDEPEND="
- app-arch/xz-utils
- app-shells/bash
- net-misc/curl
- || (
- gnome-extra/zenity
- x11-terms/xterm
- )
-
- amd64? (
- >=app-emulation/emul-linux-x86-baselibs-20121028
- || (
- >=app-emulation/emul-linux-x86-xlibs-20121028
- (
- x11-libs/libX11[abi_x86_32]
- x11-libs/libXau[abi_x86_32]
- x11-libs/libxcb[abi_x86_32]
- x11-libs/libXdmcp[abi_x86_32]
- )
- )
- >=sys-devel/gcc-4.6.0[multilib]
- >=sys-libs/glibc-2.15[multilib]
- )
- x86? (
- >=sys-devel/gcc-4.6.0
- >=sys-libs/glibc-2.15
- >=x11-libs/libX11-1.5
- x11-libs/libXau
- x11-libs/libxcb
- x11-libs/libXdmcp
- )"
-
-S=${WORKDIR}/steam/
-
-src_prepare() {
- # we use our ebuild functions to install the files
- rm Makefile
-
- sed -i \
- -e "s:/usr/bin/steam:${GAMES_BINDIR}/steam:" \
- ${S}/steam.desktop || die "sed failed"
-}
-
-src_install() {
- dogamesbin steam || die "dogamesbin failed"
-
- insinto /usr/lib/steam/
- doins bootstraplinux_ubuntu12_32.tar.xz
-
- dodoc debian/changelog steam_install_agreement.txt
- doman steam.6
-
- domenu steam.desktop
-
- cd icons/
- for s in * ; do
- doicon -s ${s} ${s}/steam.png
- done
-
- # tgz archive contains no separate pixmap, see #38
- insinto /usr/share/pixmaps/
- newins 48/steam.png steam_tray_mono.png
-
- prepgamesdirs
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-
- elog "Execute ${GAMES_BINDIR}/steam to download and install the actual"
- elog "client into your home folder. After installation, the script"
- elog "also starts the client from your home folder."
- elog ""
-
- if ! has_version "gnome-extra/zenity"; then
- ewarn "Valve does not provide a xterm fallback for all calls of zenity."
- ewarn "Please install gnome-extra/zenity for full support."
- ewarn ""
- fi
-
- ewarn "The steam client and the games are _not_ controlled by portage."
- ewarn "Updates are handled by the client itself."
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/games-util/steam-launcher/steam-launcher-1.0.0.47.ebuild b/games-util/steam-launcher/steam-launcher-1.0.0.47.ebuild
deleted file mode 100644
index 5e5487d..0000000
--- a/games-util/steam-launcher/steam-launcher-1.0.0.47.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-# Please report bugs/suggestions on: https://github.com/anyc/steam-overlay
-# or come to #gentoo-gamerlay in freenode IRC
-
-inherit eutils gnome2-utils fdo-mime
-
-DESCRIPTION="Installer, launcher and supplementary files for Valve's Steam client"
-HOMEPAGE="http://steampowered.com"
-SRC_URI="http://repo.steampowered.com/steam/archive/precise/steam_${PV}.tar.gz"
-
-KEYWORDS="-* ~amd64 ~x86"
-LICENSE="ValveSteamLicense"
-
-RESTRICT="bindist mirror"
-SLOT="0"
-
-RDEPEND="
- app-arch/xz-utils
- app-shells/bash
- net-misc/curl
- || (
- gnome-extra/zenity
- x11-terms/xterm
- )
-
- amd64? (
- >=app-emulation/emul-linux-x86-baselibs-20121028
- || (
- >=app-emulation/emul-linux-x86-xlibs-20121028
- (
- x11-libs/libX11[abi_x86_32]
- x11-libs/libXau[abi_x86_32]
- x11-libs/libxcb[abi_x86_32]
- x11-libs/libXdmcp[abi_x86_32]
- )
- )
- >=sys-devel/gcc-4.6.0[multilib]
- >=sys-libs/glibc-2.15[multilib]
- )
- x86? (
- >=sys-devel/gcc-4.6.0
- >=sys-libs/glibc-2.15
- >=x11-libs/libX11-1.5
- x11-libs/libXau
- x11-libs/libxcb
- x11-libs/libXdmcp
- )"
-
-S=${WORKDIR}/steam/
-
-src_prepare() {
- # we use our ebuild functions to install the files
- rm Makefile
-}
-
-src_install() {
- dobin steam
-
- insinto /usr/lib/steam/
- doins bootstraplinux_ubuntu12_32.tar.xz
-
- dodoc debian/changelog steam_install_agreement.txt
- doman steam.6
-
- domenu steam.desktop
-
- cd icons/
- for s in * ; do
- doicon -s ${s} ${s}/steam.png
- done
-
- # tgz archive contains no separate pixmap, see #38
- insinto /usr/share/pixmaps/
- newins 48/steam.png steam_tray_mono.png
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-
- elog "Execute /usr/bin/steam to download and install the actual"
- elog "client into your home folder. After installation, the script"
- elog "also starts the client from your home folder."
- elog ""
-
- if ! has_version "gnome-extra/zenity"; then
- ewarn "Valve does not provide a xterm fallback for all calls of zenity."
- ewarn "Please install gnome-extra/zenity for full support."
- ewarn ""
- fi
-
- ewarn "The steam client and the games are _not_ controlled by portage."
- ewarn "Updates are handled by the client itself."
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/games-util/steam-launcher/steam-launcher-1.0.0.49.ebuild b/games-util/steam-launcher/steam-launcher-1.0.0.49.ebuild
index 2f66fc5..0412e37 100644
--- a/games-util/steam-launcher/steam-launcher-1.0.0.49.ebuild
+++ b/games-util/steam-launcher/steam-launcher-1.0.0.49.ebuild
@@ -41,6 +41,7 @@ RDEPEND="
>=sys-devel/gcc-4.6.0[multilib]
>=sys-libs/glibc-2.15[multilib]
)
+
x86? (
>=sys-devel/gcc-4.6.0
>=sys-libs/glibc-2.15
@@ -48,7 +49,8 @@ RDEPEND="
x11-libs/libXau
x11-libs/libxcb
x11-libs/libXdmcp
- )"
+ )
+"
S=${WORKDIR}/steam/
@@ -57,6 +59,12 @@ src_prepare() {
# we use our ebuild functions to install the files
rm Makefile
+
+ sed -i \
+ -e "s:/usr/bin/steam:${GAMES_BINDIR}/steam:" \
+ ${S}/steam.desktop || die "sed failed"
+
+ epatch_user
}
src_install() {