summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Kicherer <dev@kicherer.org>2014-06-04 16:18:01 +0200
committerMario Kicherer <dev@kicherer.org>2014-06-04 16:27:37 +0200
commit95491010fab19dc8f200bddb12af85861c7e3353 (patch)
treec0891313fb37fda4725f132c87820cc221d92243 /games-strategy
parent[games-engines/fife] remove unused qt4 useflag (diff)
downloadgamerlay-95491010fab19dc8f200bddb12af85861c7e3353.tar.gz
gamerlay-95491010fab19dc8f200bddb12af85861c7e3353.tar.bz2
gamerlay-95491010fab19dc8f200bddb12af85861c7e3353.zip
[games-strategy/unknown-horizons] version bump 2013.3
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/unknown-horizons/Manifest1
-rw-r--r--games-strategy/unknown-horizons/unknown-horizons-2013.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/games-strategy/unknown-horizons/Manifest b/games-strategy/unknown-horizons/Manifest
index 784ba1d..5f0d8fa 100644
--- a/games-strategy/unknown-horizons/Manifest
+++ b/games-strategy/unknown-horizons/Manifest
@@ -1,3 +1,4 @@
+DIST 2013.3.tar.gz 152988408 SHA256 db9ffe365aa0be95bb808891573d4a135db980ba5a2316f1cf9a30e6505a638e SHA512 d30d4d4f077e9ad6926b2e751bad0d8bd4dca5e5760ae6d948db04f5c1a475283de016562f06c0e3afcade3444fbd4b943996dd58cb91ac0bc1ef37176de13f4 WHIRLPOOL 18930b0064030abe0552d0cb8b6f903a94983f8e468bde8cae20621148c08e4ea34d8ad12ca97d0dab741dbe177742af22759ca544087b69df848b5c0539da90
DIST unknown-horizons-2011.1a.tar.xz 64190668 SHA256 0d8adce00c144acc0b3bf73839f9dbfe84537f0465c384f1606feebc28896450
DIST unknown-horizons-2011.2.tar.xz 71843004 SHA256 f64bc787c6094f420a4d7a5f3181fd24d395034a8b2ccbea6799e7cb1ab06092
DIST unknown-horizons-2011.3-source.tar.bz2 78490453 SHA256 16a9fdbb60707f1d3e225795100f7fc061f6b7ce12656ad74ebc615b162a0ac7
diff --git a/games-strategy/unknown-horizons/unknown-horizons-2013.3.ebuild b/games-strategy/unknown-horizons/unknown-horizons-2013.3.ebuild
new file mode 100644
index 0000000..f69a564
--- /dev/null
+++ b/games-strategy/unknown-horizons/unknown-horizons-2013.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_DEPEND="2:2.7"
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_USE_WITH="sqlite"
+
+inherit python games distutils
+
+DESCRIPTION="Anno-like real time strategy game"
+HOMEPAGE="http://www.unknown-horizons.org/"
+SRC_URI="http://github.com/unknown-horizons/unknown-horizons/archive/${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pyyaml
+ dev-python/bsddb3
+ >=games-engines/fife-0.3.5"
+
+RDEPEND="$DEPEND"
+
+#S="${WORKDIR}"/${PN}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ games_pkg_setup
+}
+
+src_compile() {
+ distutils_src_compile build_i18n
+}
+
+src_prepare() {
+ # make sure version two is started for startup scripts
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ distutils_src_install
+ # fix install paths to Gentoo specific locations
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r content || die "doins failed"
+ rm -rf "${D}/usr/share/${PN}/content"
+ dogamesbin "${D}/usr/bin/${PN}" || die "dogamesbin failed"
+ rm -rf "${D}/usr/bin/"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ distutils_pkg_postinst
+}