summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2017-09-07 22:31:14 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2017-09-07 22:31:14 +0700
commit3d2ababc25d2128212c0438f29490cb1403ad621 (patch)
tree67ff54fdab61ca1cba89412cb81e2b4803c48682 /games-fps
parentlibbulletml: bump to EAPI6 + fixes (BZ#623814) (diff)
downloadgamerlay-3d2ababc25d2128212c0438f29490cb1403ad621.tar.gz
gamerlay-3d2ababc25d2128212c0438f29490cb1403ad621.tar.bz2
gamerlay-3d2ababc25d2128212c0438f29490cb1403ad621.zip
rtcw: fixed calling ext command in global scope (fixes bgo#630174)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/rtcw/rtcw-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/games-fps/rtcw/rtcw-9999.ebuild b/games-fps/rtcw/rtcw-9999.ebuild
index 961a07a..8d0b8fb 100644
--- a/games-fps/rtcw/rtcw-9999.ebuild
+++ b/games-fps/rtcw/rtcw-9999.ebuild
@@ -55,7 +55,6 @@ RDEPEND="client? ( media-libs/libsdl2
#voip? ( media-libs/speex )"
dir=${GAMES_PREFIX_OPT}/${PN}
-ARCHITECTURE=$(uname -m)
use_switch() {
local flag="${1}" cfg_option="${2}" cfg_val=0
@@ -127,6 +126,8 @@ src_prepare(){
use curl && echo "USE_CURL_DLOPEN=0" >> ${makefile}
use openal && echo "USE_OPENAL_DLOPEN=0" >> ${makefile}
+
+ export ARCHITECTURE=$(uname -m)
}
src_compile() {