summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/app-text/tmispell/tmispell-0.7.ebuild')
-rw-r--r--trunk/app-text/tmispell/tmispell-0.7.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/trunk/app-text/tmispell/tmispell-0.7.ebuild b/trunk/app-text/tmispell/tmispell-0.7.ebuild
index 54d0a28..887cfca 100644
--- a/trunk/app-text/tmispell/tmispell-0.7.ebuild
+++ b/trunk/app-text/tmispell/tmispell-0.7.ebuild
@@ -2,19 +2,19 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
+inherit eutils multilib
MY_PV=${PV/_rc/rc}
MY_P=${PN}-voikko-${MY_PV}
-DESCRIPTION="Tmispell is interface between ispell OO.o Finnish spellcheckers."
+DESCRIPTION="An interface between ispell and Voikko Finnish spellcheckers."
SRC_URI="mirror://sourceforge/voikko/${MY_P}.tar.gz"
HOMEPAGE="http://voikko.sf.net/"
IUSE="enchant nls"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
DEPEND=">=app-text/ispell-3.3.02-r90
!app-dicts/ispell-fi
@@ -26,26 +26,28 @@ DEPEND=">=app-text/ispell-3.3.02-r90
sys-apps/miscfiles
dev-util/pkgconfig
app-admin/eselect-ispell"
-RDEPEND=">=app-text/ispell-3.2.06-r7
+RDEPEND=">=app-text/ispell-3.3.02-r90
>=app-text/voikko-1.0
>=dev-libs/glib-2.0.0
- enchant? ( >=app-text/enchant-1.1.6 )
+ enchant? ( >=app-text/enchant-1.4 )
nls? ( sys-devel/gettext )"
S="${WORKDIR}/${MY_P/rc?/}"
pkg_setup() {
- if [[ -d "${ROOT}/usr/lib/ispell" ]] ; then
- ISPELL_DIR=/usr/lib/ispell
+ if [[ -d "${ROOT}/usr/$(get_libdir)/ispell" ]] ; then
+ ISPELL_DIR=/usr/$(get_libdir)/ispell
elif [[ -d "${ROOT}/usr/share/ispell" ]] ; then
ISPELL_DIR=/usr/share/ispell
else
die "Couldn’t find ispell data directory from root ${ROOT}"
fi
+ einfo "Using ${ISPELL_DIR} for ispell data"
}
src_compile() {
- econf $(use_enable enchant ) || die "econf failed"
+ # unconditional disable-enchant: provider is included in enchant-1.4
+ econf --disable-enchant || die "econf failed"
emake || die "emake failed"
}
@@ -64,3 +66,4 @@ pkg_postinst() {
elog "which want ispell working with tmispell"
eselect ispell update --if-unset
}
+