diff options
-rw-r--r-- | AUTHORS | 1 | ||||
-rw-r--r-- | ChangeLog | 1 | ||||
-rw-r--r-- | Makefile.am | 8 |
3 files changed, 10 insertions, 0 deletions
@@ -0,0 +1 @@ +sera:Ralph Sennhauser <sera@gentoo.org> @@ -0,0 +1 @@ +The ChangeLog is generated using svn2cl on `make dist`, use "svn log" instead. diff --git a/Makefile.am b/Makefile.am index f0b9a58..780af9c 100644 --- a/Makefile.am +++ b/Makefile.am @@ -16,3 +16,11 @@ EXTRA_DIST = \ COPYING \ NEWS \ README + +dist-hook: + if test -d "$(srcdir)"/.svn ; then \ + echo "Generating ChangeLog ..." ; \ + ( cd "$(top_srcdir)" && svn2cl --authors AUTHORS -o "$(top_distdir)"/ChangeLog ) ; \ + else \ + echo "Needs a svn checkout to generate a ChangeLog" ; \ + fi |