aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2009-02-01 16:09:28 +0000
committerRobert Piasek <dagger@gentoo.org>2009-02-01 16:09:28 +0000
commit7d35f3177ad4b1baf900d6d03a326a797c6eb90c (patch)
tree1275f80f9a62c73b2d1d5f140231425fb597a2b1 /x11-libs/ewl
parentoops! fucked up Manifest of openmoko-dialer3 (diff)
downloadembedded-cross-7d35f3177ad4b1baf900d6d03a326a797c6eb90c.tar.gz
embedded-cross-7d35f3177ad4b1baf900d6d03a326a797c6eb90c.tar.bz2
embedded-cross-7d35f3177ad4b1baf900d6d03a326a797c6eb90c.zip
EFL revision bump from 38500 to 38885.
EFL python bindings revision bump from 38500 to 38885
Diffstat (limited to 'x11-libs/ewl')
-rw-r--r--x11-libs/ewl/Manifest1
-rw-r--r--x11-libs/ewl/ewl-20090201-r38885.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/x11-libs/ewl/Manifest b/x11-libs/ewl/Manifest
index f5ae98c..ddca346 100644
--- a/x11-libs/ewl/Manifest
+++ b/x11-libs/ewl/Manifest
@@ -1 +1,2 @@
EBUILD ewl-20090108.ebuild 1552 RMD160 57d9e0fce4e9f6be8593950a860b747de495c239 SHA1 044f89b79450e5609aa44d6226eb9fb560793147 SHA256 5cb05373a21317153aa113a71737414e4999ff2b39f760dc8b88827d80d158ee
+EBUILD ewl-20090201-r38885.ebuild 1546 RMD160 3addb9fa0e37de27bb842d4cfcabd98864a1c4ed SHA1 0235c0a5d8bd3dbc778cba75c2a272033777162c SHA256 72d283b4569cc2aae036d5023331b5a545e81a3413ec6b1ad383cee97da741c4
diff --git a/x11-libs/ewl/ewl-20090201-r38885.ebuild b/x11-libs/ewl/ewl-20090201-r38885.ebuild
new file mode 100644
index 0000000..8ad4b95
--- /dev/null
+++ b/x11-libs/ewl/ewl-20090201-r38885.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="The Enlightenment ewl library."
+HOMEPAGE="http://enlightenment.org"
+ESVN_REPO_URI="http://svn.enlightenment.org/svn/e/trunk/${PN}"
+ESVN_REVISION="r38885"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~x86 ~amd64"
+IUSE="X xcb sdl fbcon opengl"
+
+inherit autotools subversion
+
+RDEPEND="
+ X? ( x11-libs/libXrender )
+ xcb? ( x11-misc/xcb )
+ sdl? ( media-libs/libsdl )
+ opengl? ( virtual/opengl )
+ =media-libs/emotion-${PVR}
+ =media-libs/epsilon-${PVR}"
+
+DEPEND=">=dev-util/pkgconfig-0.9.0"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ subversion_src_unpack
+
+ cd "${S}"
+
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf}
+ $(use_enable X software-x11) \
+ $(use_enable X software-16-x11) \
+ $(use_enable xcb software-xcb) \
+ $(use_enable sdl software-sdl) \
+ $(use_enable fbcon fb) \
+ $(use_enable opengl opengl-glew) \
+ $(use_enable opengl opengl-x11) \
+ $(use_enable X xrender-x11) \
+ --enable-software-buffer \
+ --x-includes=${SYSROOT}/usr/X11R6/include \
+ --x-libraries=${SYSROOT}/usr/X11R6/lib"
+
+
+ econf ${myconf} || die "Configuration failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS NEWS README
+}