aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub 'cz_jc' Novák <jc.bl.dws@gmail.com>2010-06-16 22:15:50 +0200
committerJakub 'cz_jc' Novák <jc.bl.dws@gmail.com>2010-06-16 22:15:50 +0200
commitaedc2ffb8144657c8286bfdd24bfedcdf83abe5c (patch)
tree96d5e8d32afda769197771cf43ab378ecfba8fa8 /x11-drivers
parentfix sets.conf "openmoko-target reponame" issue (diff)
downloadembedded-cross-aedc2ffb8144657c8286bfdd24bfedcdf83abe5c.tar.gz
embedded-cross-aedc2ffb8144657c8286bfdd24bfedcdf83abe5c.tar.bz2
embedded-cross-aedc2ffb8144657c8286bfdd24bfedcdf83abe5c.zip
xf86-video-glamo fixes, libdrm with glamo support
x11-drivers/xf86-video-glamo: - Converted to EAPI 2 - Added KMS use flag - Now depends on x11-libs/libdrm[video_cards_glamo] x11-libs/libdrm: - Initial commit of upstream libdrm patched with glamo support. - Changes copied from: http://git.bitwiz.org.uk/?p=libdrm.git;a=summary Original made by Thomas White et al. who hereby have our thanks. Thanks sleipnir :)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-glamo/Manifest2
-rw-r--r--x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild20
2 files changed, 19 insertions, 3 deletions
diff --git a/x11-drivers/xf86-video-glamo/Manifest b/x11-drivers/xf86-video-glamo/Manifest
index 6b59e95..6cf1014 100644
--- a/x11-drivers/xf86-video-glamo/Manifest
+++ b/x11-drivers/xf86-video-glamo/Manifest
@@ -1 +1 @@
-EBUILD xf86-video-glamo-9999.ebuild 775 RMD160 6c6b31730e0f99481a0648242b41300c601ca986 SHA1 b3ca24f3d35a447c6f75512dfb62908bb573da21 SHA256 0af09206b9a2a994a14a7088aa9da507241c3d15f72a82942d2849047e6c860a
+EBUILD xf86-video-glamo-9999.ebuild 1138 RMD160 23b37c34878c91629be8b45432441bc4b203d598 SHA1 5d835ce80c7e186e682a7354370caff0ef72751c SHA256 9badb8c3f595c443f57be4f1d6b1675ecf1e926853479b27968e4b3733d4f552
diff --git a/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild b/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild
index 7c8cede..6e93c7a 100644
--- a/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild
+++ b/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=2
XDPVER=-1
inherit x-modular git
@@ -14,7 +15,7 @@ EGIT_PROJECT="xf86-video-glamo"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~arm"
-IUSE="dri"
+IUSE="dri kms"
use dri && EGIT_BRANCH="kms"
@@ -25,7 +26,14 @@ DEPEND="${RDEPEND}
x11-proto/renderproto
x11-proto/xextproto
x11-proto/xproto
- x11-proto/videoproto"
+ x11-proto/videoproto
+ x11-libs/libdrm[video_cards_glamo]"
+
+pkg_setup() {
+ if use kms ; then
+ ewarn "If you experience build or run time difficulties, try disabling kms use flag."
+ fi
+}
src_unpack() {
git_src_unpack
@@ -35,6 +43,14 @@ src_unpack() {
eautoreconf || die "eautoreconf failed"
}
+src_compile() {
+ local myconf
+ myconf="${myconf} --disable-kms"
+ use kms && myconf="${myconf} --enable-kms"
+
+ econf ${myconf} || die "Configuration failed"
+ emake || die "Make failed"
+}
src_install() {
x-modular_src_install