aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-02-19 07:41:26 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-02-19 07:41:26 +0000
commit7a05004f1e46dac1595450e0d7d832e9b64a589f (patch)
tree775a62317eef906af579111c26288d4b5455792b /sci-geosciences
parentFix another python cross-compile monster that pulled in -L/usr/lib! I hope we... (diff)
downloadembedded-cross-7a05004f1e46dac1595450e0d7d832e9b64a589f.tar.gz
embedded-cross-7a05004f1e46dac1595450e0d7d832e9b64a589f.tar.bz2
embedded-cross-7a05004f1e46dac1595450e0d7d832e9b64a589f.zip
Autotoolize pkg-config in GPSd, remove the DEPEND=RDEPEND oddity and cleanup the useflag mess a bit.
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/Manifest3
-rw-r--r--sci-geosciences/gpsd/files/gpsd-2.37-autotoolize-pkg-config.patch26
-rw-r--r--sci-geosciences/gpsd/gpsd-2.37.ebuild185
3 files changed, 214 insertions, 0 deletions
diff --git a/sci-geosciences/gpsd/Manifest b/sci-geosciences/gpsd/Manifest
new file mode 100644
index 0000000..829705f
--- /dev/null
+++ b/sci-geosciences/gpsd/Manifest
@@ -0,0 +1,3 @@
+AUX gpsd-2.37-autotoolize-pkg-config.patch 911 RMD160 ad6f14a2fece9680c1f51beab9643aae3a264cd5 SHA1 89c2d709639be65248494735d89b9a605514485e SHA256 c19e0cd7adeb135746f348683261ff1a441e35edcbea8fbf28c0aeab97e5bb08
+DIST gpsd-2.37.tar.gz 712943 RMD160 72387ef3c8da39ed1a1dffa9aecfff1622023fcc SHA1 5bf4e1db9e570cc14b70bd0cf902926f96131ace SHA256 8860e61edc26f0665ad6ea0b34be4e3fd2cc7c51c5fd63b25c857a1870e8e137
+EBUILD gpsd-2.37.ebuild 5232 RMD160 7fb06ae52bcf77ec38ed98a2c0bba23d83c7f583 SHA1 64754f0660d276fac7d67215648814de2f4018c8 SHA256 6056d6ac5d284a9188e92fb6cc8eeb709beea37a679ef0d864d1c5db67eb528d
diff --git a/sci-geosciences/gpsd/files/gpsd-2.37-autotoolize-pkg-config.patch b/sci-geosciences/gpsd/files/gpsd-2.37-autotoolize-pkg-config.patch
new file mode 100644
index 0000000..4e8078a
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-2.37-autotoolize-pkg-config.patch
@@ -0,0 +1,26 @@
+--- configure.ac 2009-02-19 08:02:23.000000000 +0100
++++ configure.ac.new 2009-02-19 08:03:58.000000000 +0100
+@@ -15,6 +15,7 @@
+ ac_python="yes"
+ fi
+ AM_CONDITIONAL([HAVE_PYTHON], [test x"$ac_python" = xyes])
++PKG_PROG_PKG_CONFIG
+
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+@@ -567,12 +568,12 @@
+ AC_DEFINE([DBUS_ENABLE], 1, [DBUS support])
+ # Older versions of autotools barf and die on this.
+ #PKG_CHECK_MODULES(DBUS, dbus-1 >= 0.23.4 )
+- DBUS_CFLAGS=`pkg-config --cflags dbus-glib-1`
+- DBUS_LIBS=`pkg-config --libs dbus-1`
++ DBUS_CFLAGS=`$PKG_CONFIG --cflags dbus-glib-1`
++ DBUS_LIBS=`$PKG_CONFIG --libs dbus-1`
+ AC_SUBST(DBUS_CFLAGS)
+ AC_SUBST(DBUS_LIBS)
+ #PKG_CHECK_MODULES(DBUS_GLIB, dbus-glib-1 >= 0.22 )
+- DBUS_GLIB_LIBS=`pkg-config --libs dbus-glib-1`
++ DBUS_GLIB_LIBS=`$PKG_CONFIG --libs dbus-glib-1`
+ AC_SUBST(DBUS_GLIB_CFLAGS)
+ AC_SUBST(DBUS_GLIB_LIBS)
+ else
diff --git a/sci-geosciences/gpsd/gpsd-2.37.ebuild b/sci-geosciences/gpsd/gpsd-2.37.ebuild
new file mode 100644
index 0000000..a7a5262
--- /dev/null
+++ b/sci-geosciences/gpsd/gpsd-2.37.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.37.ebuild,v 1.4 2008/12/21 17:56:11 nerdboy Exp $
+
+inherit eutils distutils autotools
+
+DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients."
+HOMEPAGE="http://gpsd.berlios.de/"
+SRC_URI="mirror://berlios/gpsd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="dbus italk itrax minimal ntp python usb X"
+# tnt support is broken in this version - add tntc back when fixed
+
+RDEPEND="X? (
+ x11-libs/libXmu
+ x11-libs/libXext
+ x11-libs/libXp
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXpm
+ x11-libs/libXaw
+ x11-libs/openmotif
+ )
+ python? ( dev-lang/python )
+
+ dbus? ( >=sys-apps/dbus-0.94
+ >=dev-libs/glib-2.6
+ dev-libs/dbus-glib )
+ ntp? ( net-misc/ntp )
+ usb? ( virtual/dev-manager )"
+
+DEPEND="X? (
+ x11-proto/xproto
+ x11-proto/xextproto
+ )
+ !minimal? (
+ dev-libs/libxslt
+ sys-libs/ncurses
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e \
+ "s:gpspacket\", extension_source)]:gpspacket\", extension_source, libraries=['m'])]:g" \
+ setup.py || die "sed failed"
+
+ # Autotoolize pkg-config for better cross-compiling support
+ epatch "${FILESDIR}/${P}-autotoolize-pkg-config.patch"
+
+ # We need to reconfigure the whole thing because of the
+ # patch above
+ touch NEWS
+ touch Changelog
+ eautoreconf || die "Autoreconfiguration failed"
+}
+
+src_compile() {
+
+ local my_conf=""
+
+ use python && distutils_python_version
+
+ myconf="${myconf}
+ $(use_enable ntp ntpshm) \
+ $(use_enable ntp pps) \
+ $(use_enable dbus) \
+ $(use_enable italk) \
+ $(use_enable itrax) \
+ $(use_enable python) \
+ --enable-shared \
+ --with-pic \
+ --enable-static"
+
+ # Garmin support is broken in this version
+ myconf="${myconf} --disable-garmin --disable-garmintxt"
+
+ # Support for the TNT digital compass is currently broken
+ # $(use_enable tntc tnt)
+
+ if use minimal; then
+ local max_clients="5"
+ local max_devices="2"
+
+ my_conf="${my_conf} \
+ --enable-squelch \
+ --without-x \
+ --enable-max-devices=${max_devices} \
+ --enable-max-clients=${max_clients}"
+
+ WITH_XSLTPROC=no WITH_XMLTO=no econf ${my_conf} || die "econf failed"
+ else
+ my_conf="${my_conf} \
+ $(use_with X x)"
+
+ econf ${my_conf} || die "econf failed"
+ fi
+
+ # still needs an explicit linkage with the math lib (bug #250757)
+ append-ldflags -lm
+
+ emake || die "emake failed"
+}
+
+src_install() {
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ if use usb ; then
+ insinto /etc/hotplug/usb
+ doins gpsd.usermap
+ exeinto /etc/hotplug/usb
+ doexe gpsd.hotplug
+ insinto /etc/udev/rules.d
+ doins "${FILESDIR}"/99-gpsd-usb.rules
+ keepdir /var/run/usb # needed for REMOVER
+ else
+ newconfd "${FILESDIR}"/gpsd.conf gpsd
+ newinitd "${FILESDIR}"/gpsd.init gpsd
+ fi
+
+ if use X && ! use minimal ; then
+ insinto /etc/X11/app-defaults
+ newins xgps.ad Xgps
+ newins xgpsspeed.ad Xgpsspeed
+ else
+ rm "${D}usr/share/man/man1/xgpsspeed.1.bz2" \
+ "${D}usr/share/man/man1/xgps.1.bz2"
+ fi
+
+ diropts "-m0644"
+ dobin logextract
+
+ if use python ; then
+ exeinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doexe gps.py gpsfake.py gpspacket.so
+ fi
+
+ if use minimal; then
+ doman gpsctl.1 gpsflash.1 gpspipe.1 gpsd.8 gps.1
+ use python && doman gpsprof.1 gpsfake.1 gpscat.1
+ fi
+
+ dodoc INSTALL README TODO
+
+ # add missing include file (see bug #162361)
+ insinto /usr/include
+ doins gpsd_config.h
+}
+
+pkg_postinst() {
+ elog ""
+ elog "This version of gpsd has broken the support for the TNT compass"
+ elog "and Garmin so they are disabled. If you need it, stay with the"
+ elog "previous version for now. The minimal flag now removes X and"
+ elog "enables the embedded device (ie, small footprint) support, but"
+ elog "you'll need to modify the ebuild if you need to change either"
+ elog "the number of clients or the number of devices. Although pps"
+ elog "is enabled, it still needs the correct kernel patches. All"
+ elog "recent versions of udev (>=udev-115 or so) should have correct"
+ elog "usb device detection and startup of gpsd (ie, without hotplug)."
+ elog ""
+ elog "Different GPS devices require the corresponding kernel options"
+ elog "to be enabled, such as USB_SERIAL_GARMIN, or a USB serial driver"
+ elog "for an adapter such as those that come with Deluo GPS units (eg,"
+ elog "USB_SERIAL_PL2303). Straight serial devices should always work,"
+ elog "even without udev/hotplug support."
+ elog ""
+ elog "Note: the supplied gpsd udev rules are now device-specific, so"
+ elog "if your device isn't detected correctly, please use lsusb or"
+ elog "another suitable tool to determine the proper device IDs and"
+ elog "use the commented rules to fill in the blanks for your device."
+ elog "Please file a bug to get your device added to the list."
+ elog ""
+ elog "Read the INSTALL doc for more information on supported hardware,"
+ elog "and make sure udev has the right group permissions set on the tty"
+ elog "devices if using USB (it should Do The Right Thing (TM))..."
+ elog ""
+}