aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ebuild-writing/functions/pkg_postinst/text.xml7
-rw-r--r--ebuild-writing/messages/text.xml30
-rw-r--r--function-reference/message-functions/text.xml8
-rw-r--r--xsl/lang.highlight.ebuild.xsl3
4 files changed, 36 insertions, 12 deletions
diff --git a/ebuild-writing/functions/pkg_postinst/text.xml b/ebuild-writing/functions/pkg_postinst/text.xml
index 254fcfe..accfc16 100644
--- a/ebuild-writing/functions/pkg_postinst/text.xml
+++ b/ebuild-writing/functions/pkg_postinst/text.xml
@@ -50,10 +50,9 @@ pkg_postinst() {
ewarn "feature if you are upgrading from an older fluxbox!"
ewarn " "
fi
- einfo "If you experience font problems, or if fluxbox takes a very"
- einfo "long time to start up, please try the 'disablexmb' USE flag."
- einfo "If that fails, please report bugs upstream."
- epause
+ elog "If you experience font problems, or if fluxbox takes a very"
+ elog "long time to start up, please try the 'disablexmb' USE flag."
+ elog "If that fails, please report bugs upstream."
}
</codesample>
</body>
diff --git a/ebuild-writing/messages/text.xml b/ebuild-writing/messages/text.xml
index 65c3c1e..dcceee9 100644
--- a/ebuild-writing/messages/text.xml
+++ b/ebuild-writing/messages/text.xml
@@ -21,8 +21,8 @@ out.
<p>
In all cases, assume that the user's terminal is no wider than 79 columns, and
-that the <c>einfo</c>, <c>ewarn</c> and <c>eerror</c> functions will occupy 4 columns
-with their fancy leading markers.
+that the <c>elog</c>,<c>einfo</c>, <c>ewarn</c> and <c>eerror</c> functions will
+occupy 4 columns with their fancy leading markers.
</p>
</body>
@@ -37,16 +37,32 @@ internal is the simplest <d/> it simply displays its parameters as a message.
</p>
<p>
+The <c>elog</c> function can be used to display an informational message which is
+meant to 'stand out' and is logged by the elog functionality in Portage 2.1 and
+Paludis 0.6 or newer. On a colour terminal, the message provided will be prefixed
+with a green asterisk. On earlier versions, elog behaves just like einfo.
+</p>
+
+<codesample lang="ebuild">
+pkg_postinst() {
+ elog "You will need to set up your /etc/foo/foo.conf file before"
+ elog "running foo for the first time. For details, please see the"
+ elog "foo.conf(5) manual page."
+}
+</codesample>
+
+
+<p>
The <c>einfo</c> function can be used to display an informational message which is
meant to 'stand out'. On a colour terminal, the message provided will be
-prefixed with a green asterisk.
+prefixed with a green asterisk. einfo messages go to the INFO elog class which is not
+logged by default.
</p>
<codesample lang="ebuild">
-pkg_postinst() {
- einfo "You will need to set up your /etc/foo/foo.conf file before"
- einfo "running foo for the first time. For details, please see the"
- einfo "foo.conf(5) manual page."
+src_compile() {
+ einfo "Starting a silent compile that takes hours."
+ ./build
}
</codesample>
diff --git a/function-reference/message-functions/text.xml b/function-reference/message-functions/text.xml
index d702264..8df5380 100644
--- a/function-reference/message-functions/text.xml
+++ b/function-reference/message-functions/text.xml
@@ -36,6 +36,14 @@ displaying informational messages.
</tr>
<tr>
<ti>
+ <c>elog</c>
+ </ti>
+ <ti>
+ Display an informational message, to be logged if logging is enabled.
+ </ti>
+ </tr>
+ <tr>
+ <ti>
<c>ewarn</c>
</ti>
<ti>
diff --git a/xsl/lang.highlight.ebuild.xsl b/xsl/lang.highlight.ebuild.xsl
index 4185396..554ea26 100644
--- a/xsl/lang.highlight.ebuild.xsl
+++ b/xsl/lang.highlight.ebuild.xsl
@@ -111,7 +111,8 @@
<!-- Default keywords -->
<xsl:when test="$data = 'use' or $data = 'has_version' or $data = 'best_version' or $data = 'use_with' or $data = 'use_enable' or
- $data = 'check_KV' or $data = 'keepdir' or $data = 'econf' or $data = 'die' or $data = 'einstall' or $data = 'einfo' or
+ $data = 'check_KV' or $data = 'keepdir' or $data = 'econf' or $data = 'die' or $data = 'einstall' or $data = 'einfo' or
+ $data = 'elog' or
$data = 'ewarn' or $data = 'eerror' or $data = 'diropts' or $data = 'dobin' or $data = 'docinto' or $data = 'dodoc' or
$data = 'doexe' or $data = 'dohard' or $data = 'dohtml' or $data = 'doinfo' or $data = 'doins' or $data = 'dolib' or
$data = 'dolib$dataa' or $data = 'dolib$dataso' or $data = 'doman' or $data = 'dosbin' or $data = 'dosym' or $data = 'emake' or