aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Thibodeau <kyron@neuralbs.com>2008-10-20 10:40:26 -0400
committerEric Thibodeau <kyron@neuralbs.com>2008-10-20 10:40:26 -0400
commitdcb97b9e828ca66203868ac9df7255c3af6586ed (patch)
tree7bcbf4f2f13e77c6d04c46b809b600b9c5da074a
parent- added openldap to overlay to isolate shadow dependency during catalyst buil... (diff)
downloadclustering-livecd-dcb97b9e828ca66203868ac9df7255c3af6586ed.tar.gz
clustering-livecd-dcb97b9e828ca66203868ac9df7255c3af6586ed.tar.bz2
clustering-livecd-dcb97b9e828ca66203868ac9df7255c3af6586ed.zip
LiveCD-HOWTO: Documentation update to reflect latest portage changes
TODO: Notes on nfsroot image creation
-rw-r--r--LiveCD-HOWTO31
-rw-r--r--TODO12
2 files changed, 30 insertions, 13 deletions
diff --git a/LiveCD-HOWTO b/LiveCD-HOWTO
index 6966a21..ae10cb4 100644
--- a/LiveCD-HOWTO
+++ b/LiveCD-HOWTO
@@ -28,36 +28,41 @@ If you want to be able to create liveCDs with as little hassle as possible you w
# you can set CFLAGS here but it's not recommended
# NOTE, don't try to use distcc, it's broken, the distcc user is not being created in the catalyst build
- - http://sources.gentoo.org/viewcvs.py/releng/ pulled in as /var/svnroot/releng
- mkdir -p /var/svnroot/
- cd /var/svnroot/
- svn co svn://anonsvn.gentoo.org/releng
+# releng is no longer required
+## - http://sources.gentoo.org/viewcvs.py/releng/ pulled in as /var/svnroot/releng
+## mkdir -p /var/svnroot/
+## cd /var/svnroot/
+## svn co svn://anonsvn.gentoo.org/releng
- A recent snapshot (last one used was portage-20080806.tar.bz2), you have to modify the catalyst .spec files accordingly
So get a snapshot and place it in /var/tmp/catalyst/snapshots (we are doing something evil here...):
wget ftp://mirrors.tera-byte.com/pub/gentoo/snapshots/portage-20080806.tar.bz2 -O /var/tmp/catalyst/snapshots/portage-20080806.tar.bz2
+*NOTE*: You have to modify the spec files accordingly (so they point to the correct portage snapshot). There is a _crude_ script that automates
+this within the root of the repository and is used as such:
+
+./switchshapshot.sh 20081014
+
+In this example, all specs will use a snapshot from 20081014 (which you have to download into "/var/tmp/catalyst/snapshots"
+
- A recent stage3, this eliminates many problems related to circular dependancies and collisions. We used drobbin's packages from funtoo.org
mkdir -p /var/tmp/catalyst/builds/drobbins/
cd /var/tmp/catalyst/builds/drobbins/
wget http://www.funtoo.org/linux/amd64/funtoo-amd64-2008.06.27/stage3-amd64-2008.06.27.tar.bz2
+*NOTE* Again, changing seed source for the ebuilds implies modification to the stage1 spec files. No script this time, do it by editing the
+source_subpath parameter in two following spec files:
+
+ ./catalyst/nfsroot/2008.0/specs/amd64/stage1.spec
+ ./catalyst/livecd/2008.0/specs/amd64/stage1.spec
+
- This git checked out into /var/git/:
mkdir -p /var/git/
cd /var/git/
git clone git://git.overlays.gentoo.org/proj/clustering-livecd.git
- - The abovementionned snapshot suffers from the following bugs (whch have been fixed if you take something more recent):
- ** This bug isn't going to be resolved any time soon:
- http://bugs.gentoo.org/show_bug.cgi?id=142637 "missing dependency in eutils.eclass"
-
- So you have to edit the openldap ebuild (currently the setup pulls in 2.4.10) and add DEPEND="sys-apps/shadow":
-
- vi /var/tmp/catalyst/snapshot_cache/20080629/portage/net-nds/openldap/openldap-2.4.10.ebuild
- ebuild /var/tmp/catalyst/snapshot_cache/20080629/portage/net-nds/openldap/openldap-2.4.10.ebuild digest
-
- We also need (some) overlays:
# NOTE!!! I set up my layman to put all files into /usr/local/portage/ (and not de thefault of /usr/portage/local)
# If you don't like this, setup the .spec files accrodingly
diff --git a/TODO b/TODO
index 17ac144..94388be 100644
--- a/TODO
+++ b/TODO
@@ -1,3 +1,15 @@
+beowulf-head ebuild:
+
+The beowulf-head ebild requires that the NFS bootable image exists in /tftproot/nfsroot/$ARCH prior to calling pkg_config. Currently, this folder is populated thanks to the following sequence:
+
+ mkdir -p /tftproot/nfsroot/$ARCH
+ tar -xjf /var/tmp/catalyst/builds/default/stage4-$ARCH-nfsroot.tar.bz2 \
+ -C /tftproot/nfsroot/$ARCH
+
+Where stage4-$ARCH-nfsroot.tar.bz2 is a stage4 package created using the NFSroot-HOWTO.
+
+We need to find a way to either automate the image creation via an ebuild or provide such an image wthat could be downloadable and add it as a config parameter to cluster.conf (ie: NFS_ROOT_IMAGE=stage4-$ARCH-nfsroot.tar.bz2) and let pkg_config perform the above sequence.
+
Code:
cluster-setup