aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Thibodeau <kyron@neuralbs.com>2008-07-02 00:18:15 -0400
committerEric Thibodeau <kyron@neuralbs.com>2008-07-02 00:18:15 -0400
commit7e3afb36c6a10cc9287cf0258ec9417fec56754a (patch)
treea30109de4bcd70cb0302d76d79cb7ca48bc05ced
parentPath correction to .spec files and added LiveCD-HOWTO (diff)
downloadclustering-livecd-7e3afb36c6a10cc9287cf0258ec9417fec56754a.tar.gz
clustering-livecd-7e3afb36c6a10cc9287cf0258ec9417fec56754a.tar.bz2
clustering-livecd-7e3afb36c6a10cc9287cf0258ec9417fec56754a.zip
Adding LiveCD-HOWTO
-rw-r--r--LiveCD-HOWTO63
1 files changed, 63 insertions, 0 deletions
diff --git a/LiveCD-HOWTO b/LiveCD-HOWTO
new file mode 100644
index 0000000..3e7195c
--- /dev/null
+++ b/LiveCD-HOWTO
@@ -0,0 +1,63 @@
+# Eric Thibodeau
+# 01 Jul 2008
+# Google Summer of Code 2008: Gentoo Clustering LiveCD
+
+## The build environment ##
+
+If you want to be able to create liveCDs with as little hassle as possible you will need the following:
+
+ - dev-util/catalyst (am using CVS version which is close to 2.0.6)
+ ** for some reason, catalyst won't create the skeleton dirs so here is the sequence to get you started
+
+ emerge dev-util/catalyst
+ mkdir -p /var/tmp/catalyst/ /var/tmp/catalyst/snapshots /var/tmp/catalyst/tmp/default
+ # edit /etc/catalyst/catalystrc and add relevant options such as:
+ export MAKEOPTS="-j6"
+ export FEATURES="parallel-fetch"
+ # you can set CFLAGS here but it's not recommended
+ # edit /etc/catalyst/catalyst.conf and enable ccache (make sure you built it with USE=ccache)
+ # and DISABLE distcc (it was broken the last time I tried to use it)
+ options="autoresume ccache kerncache metadata_overlay pkgcache seedcache snapcache "
+
+ - http://sources.gentoo.org/viewcvs.py/releng/ pulled in as /var/svnroot/releng
+ mkdir -p /var/svnroot/
+ cd /var/svnroot/
+ svn co svn://anonsvn.gentoo.org/releng
+
+ - A recent snapshot (last one used was portage-20080629.tar.bz2), you have to modify the catalyst .spec files accordingly
+ ** as soon as we get an official 2008.0 release, I will adapt the spect files to that official, nailed down reference **
+ So get a snapshot and place it in /var/tmp/catalyst/snapshots (we are doing something evil here...):
+
+ wget ftp://mirrors.tera-byte.com/pub/gentoo/snapshots/portage-latest.tar.bz2 -O /var/tmp/catalyst/snapshots/portage-20080629.tar.bz2
+
+ - The abovementionned snapshot suffers from the following problems:
+ http://bugs.gentoo.org/show_bug.cgi?id=229103 "www-client/mozilla-firefox-bin-2.0.0.14 missing pango-dependency"
+ http://bugs.gentoo.org/show_bug.cgi?id=206753 "gnome-base/gnome-desktop-2.20.3 - parser errors during emerge"
+
+ - This git checked out into /var/git/:
+
+ mkdir -p /var/git/
+ cd /var/git/
+ git clone git://git.overlays.gentoo.org/proj/clustering-livecd.git
+
+## Actually building the CD ##
+
+** NOTE: if you have lots of RAM: **
+ You can build everything in RAM with no problems as long as tmpfs has at least 6Gigs (for the LiveCD stages)
+ mount -t tmpfs -o size=6G,noatime catalystbuild /var/tmp/catalyst/tmp/default
+**
+
+ # Barring the bugs 229103 and 206753, the following sequence should get you down to a LiveCD (haha...HAHA...HAHAHAHAHA)
+
+ cd clustering-livecd/catalyst/releases/2008.0/specs/amd64/
+ for I in stage*
+ do
+ catalyst -f $I
+ # we empty out stuff we don't need anymore ;)
+ umount /var/tmp/catalyst/tmp/default
+ mount -t tmpfs -o size=6G,noatime catalystbuild /var/tmp/catalyst/tmp/default
+ done
+ catalyst -f livecd-stage1.spec
+ catalyst -f livecd-stage2.spec
+
+ # At the end, an iso image should be waiting for you in your $HOME dir ;)