summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrent Baude <ranger@gentoo.org>2007-05-02 21:09:47 +0000
committerBrent Baude <ranger@gentoo.org>2007-05-02 21:09:47 +0000
commitf87a478aab2b5bd95567421f39180d712c94683d (patch)
tree02d974902dd7b05f193a6ca47283fcf49e7579ac
parentsvn path=/; revision=9 (diff)
downloadcell-f87a478aab2b5bd95567421f39180d712c94683d.tar.gz
cell-f87a478aab2b5bd95567421f39180d712c94683d.tar.bz2
cell-f87a478aab2b5bd95567421f39180d712c94683d.zip
A new ebuild
svn path=/; revision=10
-rw-r--r--app-misc/ps3pf_utils/ps3pf_utils-1.0.10.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/ps3pf_utils/ps3pf_utils-1.0.10.ebuild b/app-misc/ps3pf_utils/ps3pf_utils-1.0.10.ebuild
new file mode 100644
index 0000000..9ec52fd
--- /dev/null
+++ b/app-misc/ps3pf_utils/ps3pf_utils-1.0.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit flag-o-matic
+
+DESCRIPTION="Utilities to set the ps3 specific features"
+HOMEPAGE="http://www.playstation.com/ps3-openplatform/index.html"
+#SRC_URI="http://www.powerdeveloper.org/files/Cell/SourceCD/${P}.tar.bz2
+SRC_URI="http://dev.gentoo.org/~ranger/downloads/ps3/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc ppc64"
+IUSE=""
+
+# fixme: depend on a version of sys-kernel/linux-headers that supports ps3
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ append-flags -I/usr/src/linux/include/
+ emake CFLAGS="${CFLAGS}" || die "compile failed, do you have up to date kernel sources?"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "install failed"
+}