aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Edgar <rocket@gentoo.org>2006-01-26 19:56:32 +0000
committerEric Edgar <rocket@gentoo.org>2006-01-26 19:56:32 +0000
commit6a1da1220d4725770786bba58a3cde41c6fdafef (patch)
tree35f1db4fec25f0ebb20be0d18dc4af28311b3ae9 /examples
parentIt helps if I actually increment the version number. (diff)
downloadcatalyst-6a1da1220d4725770786bba58a3cde41c6fdafef.tar.gz
catalyst-6a1da1220d4725770786bba58a3cde41c6fdafef.tar.bz2
catalyst-6a1da1220d4725770786bba58a3cde41c6fdafef.zip
Separation of kerncache from snapcache
git-svn-id: svn+ssh://svn.gentoo.org/var/svnroot/catalyst/trunk@1043 d1e1f19c-881f-0410-ab34-b69fee027534
Diffstat (limited to 'examples')
-rw-r--r--examples/generic_stage_template.spec6
-rw-r--r--examples/grp_template.spec7
-rw-r--r--examples/livecd-stage1_template.spec5
-rw-r--r--examples/livecd-stage2_template.spec7
-rw-r--r--examples/netboot2_template.spec7
-rw-r--r--examples/netboot_template.spec7
-rw-r--r--examples/stage4_template.spec7
-rw-r--r--examples/tinderbox_template.spec7
8 files changed, 53 insertions, 0 deletions
diff --git a/examples/generic_stage_template.spec b/examples/generic_stage_template.spec
index 4094890c..7bc3d9ce 100644
--- a/examples/generic_stage_template.spec
+++ b/examples/generic_stage_template.spec
@@ -91,3 +91,9 @@ cxxflags:
# example:
# ldflags: -Wl,-O1 -Wl,-z,now
ldflags:
+
+# Setting the option overrides the location of the pkgcache
+pkgcache_path:
+
+# Setting the option overrides the location of the kerncache
+kerncache_path:
diff --git a/examples/grp_template.spec b/examples/grp_template.spec
index 3e5e3163..4ccbc2e3 100644
--- a/examples/grp_template.spec
+++ b/examples/grp_template.spec
@@ -106,3 +106,10 @@ grp/cd2/type:
# example:
# grp/cd2/packages: dante tsocks sys-apps/eject minicom links acpid apmd parted whois tcpdump cvs zip unzip netcat partimage app-admin/sudo app-cdr/cdrtools gnome emacs dev-lang/ruby enlightenment kde mozilla-firefox mozilla-thunderbird xfce4 openbox fluxbox sylpheed openoffice-bin gimp xemacs xmms abiword gaim xchat pan tetex xcdroast k3b samba nmap gradm ettercap ethereal mplayer
grp/cd2/packages:
+
+# Setting the option overrides the location of the pkgcache
+pkgcache_path:
+
+# Setting the option overrides the location of the kerncache
+kerncache_path:
+
diff --git a/examples/livecd-stage1_template.spec b/examples/livecd-stage1_template.spec
index cadeac20..529881b7 100644
--- a/examples/livecd-stage1_template.spec
+++ b/examples/livecd-stage1_template.spec
@@ -80,3 +80,8 @@ livecd/use:
# example:
# livecd/packages: livecd-tools dhcpcd acpid apmd gentoo-sources coldplug fxload irssi gpm syslog-ng parted links raidtools dosfstools nfs-utils jfsutils xfsprogs e2fsprogs reiserfsprogs ntfsprogs pwgen rp-pppoe screen mirrorselect penggy iputils hwdata-knoppix hwsetup lvm2 evms vim pptpclient mdadm ethtool wireless-tools prism54-firmware wpa_supplicant
livecd/packages:
+
+# Setting the option overrides the location of the pkgcache
+pkgcache_path:
+
+
diff --git a/examples/livecd-stage2_template.spec b/examples/livecd-stage2_template.spec
index 770ef1d3..97d39391 100644
--- a/examples/livecd-stage2_template.spec
+++ b/examples/livecd-stage2_template.spec
@@ -318,3 +318,10 @@ livecd/empty:
# example:
# livecd/rm: /lib/*.a /usr/lib/*.a /usr/lib/gcc-lib/*/*/libgcj* /etc/dispatch-conf.conf /etc/etc-update.conf /etc/*- /etc/issue* /etc/make.conf /etc/man.conf /etc/*.old /root/.viminfo /usr/sbin/bootsplash* /usr/sbin/fb* /usr/sbin/fsck.cramfs /usr/sbin/fsck.minix /usr/sbin/mkfs.minix /usr/sbin/mkfs.bfs /usr/sbin/mkfs.cramfs /lib/security/pam_access.so /lib/security/pam_chroot.so /lib/security/pam_debug.so /lib/security/pam_ftp.so /lib/security/pam_issue.so /lib/security/pam_mail.so /lib/security/pam_motd.so /lib/security/pam_mkhomedir.so /lib/security/pam_postgresok.so /lib/security/pam_rhosts_auth.so /lib/security/pam_userdb.so /usr/share/consolefonts/1* /usr/share/consolefonts/7* /usr/share/consolefonts/8* /usr/share/consolefonts/9* /usr/share/consolefonts/A* /usr/share/consolefonts/C* /usr/share/consolefonts/E* /usr/share/consolefonts/G* /usr/share/consolefonts/L* /usr/share/consolefonts/M* /usr/share/consolefonts/R* /usr/share/consolefonts/a* /usr/share/consolefonts/c* /usr/share/consolefonts/dr* /usr/share/consolefonts/g* /usr/share/consolefonts/i* /usr/share/consolefonts/k* /usr/share/consolefonts/l* /usr/share/consolefonts/r* /usr/share/consolefonts/s* /usr/share/consolefonts/t* /usr/share/consolefonts/v* /etc/splash/livecd-2005.0/16* /etc/splash/livecd-2005.0/12* /etc/splash/livecd-2005.0/6* /etc/splash/livecd-2005.0/8* /etc/splash/livecd-2005.0/images/silent-16* /etc/splash/livecd-2005.0/images/silent-12* /etc/splash/livecd-2005.0/images/silent-6* /etc/splash/livecd-2005.0/images/silent-8* /etc/splash/livecd-2005.0/images/verbose-16* /etc/splash/livecd-2005.0/images/verbose-12* /etc/splash/livecd-2005.0/images/verbose-6* /etc/splash/livecd-2005.0/images/verbose-8* /etc/make.conf.example /etc/make.globals /etc/resolv.conf
livecd/rm:
+
+# Setting the option overrides the location of the pkgcache
+pkgcache_path:
+
+# Setting the option overrides the location of the kerncache
+kerncache_path:
+
diff --git a/examples/netboot2_template.spec b/examples/netboot2_template.spec
index a1bd1351..fe10b274 100644
--- a/examples/netboot2_template.spec
+++ b/examples/netboot2_template.spec
@@ -286,3 +286,10 @@ netboot2/packages/xfsprogs/files:
/sbin/fsck.xfs
/sbin/mkfs.xfs
/sbin/xfs_repair
+
+# Setting the option overrides the location of the pkgcache
+pkgcache_path:
+
+# Setting the option overrides the location of the kerncache
+kerncache_path:
+
diff --git a/examples/netboot_template.spec b/examples/netboot_template.spec
index 41d3335d..2caf28fb 100644
--- a/examples/netboot_template.spec
+++ b/examples/netboot_template.spec
@@ -124,3 +124,10 @@ netboot/packages/reiserfsprogs/files:
# example:
# netboot/extra_files: /lib/libresolv.so.2 /lib/libnss_compat.so.2 /lib/libnss_dns.so.2 /lib/libnss_files.so.2 /sbin/consoletype
netboot/extra_files:
+
+# Setting the option overrides the location of the pkgcache
+pkgcache_path:
+
+# Setting the option overrides the location of the kerncache
+kerncache_path:
+
diff --git a/examples/stage4_template.spec b/examples/stage4_template.spec
index e523d50f..f5d87f79 100644
--- a/examples/stage4_template.spec
+++ b/examples/stage4_template.spec
@@ -256,3 +256,10 @@ stage4/empty:
# example:
# stage4/rm: /lib/*.a /usr/lib/*.a /usr/lib/gcc-lib/*/*/libgcj* /etc/dispatch-conf.conf /etc/etc-update.conf /etc/*- /etc/issue* /etc/make.conf /etc/man.conf /etc/*.old /root/.viminfo /usr/sbin/bootsplash* /usr/sbin/fb* /usr/sbin/fsck.cramfs /usr/sbin/fsck.minix /usr/sbin/mkfs.minix /usr/sbin/mkfs.bfs /usr/sbin/mkfs.cramfs /lib/security/pam_access.so /lib/security/pam_chroot.so /lib/security/pam_debug.so /lib/security/pam_ftp.so /lib/security/pam_issue.so /lib/security/pam_mail.so /lib/security/pam_motd.so /lib/security/pam_mkhomedir.so /lib/security/pam_postgresok.so /lib/security/pam_rhosts_auth.so /lib/security/pam_userdb.so /usr/share/consolefonts/1* /usr/share/consolefonts/7* /usr/share/consolefonts/8* /usr/share/consolefonts/9* /usr/share/consolefonts/A* /usr/share/consolefonts/C* /usr/share/consolefonts/E* /usr/share/consolefonts/G* /usr/share/consolefonts/L* /usr/share/consolefonts/M* /usr/share/consolefonts/R* /usr/share/consolefonts/a* /usr/share/consolefonts/c* /usr/share/consolefonts/dr* /usr/share/consolefonts/g* /usr/share/consolefonts/i* /usr/share/consolefonts/k* /usr/share/consolefonts/l* /usr/share/consolefonts/r* /usr/share/consolefonts/s* /usr/share/consolefonts/t* /usr/share/consolefonts/v* /etc/splash/livecd-2005.0/16* /etc/splash/livecd-2005.0/12* /etc/splash/livecd-2005.0/6* /etc/splash/livecd-2005.0/8* /etc/splash/livecd-2005.0/images/silent-16* /etc/splash/livecd-2005.0/images/silent-12* /etc/splash/livecd-2005.0/images/silent-6* /etc/splash/livecd-2005.0/images/silent-8* /etc/splash/livecd-2005.0/images/verbose-16* /etc/splash/livecd-2005.0/images/verbose-12* /etc/splash/livecd-2005.0/images/verbose-6* /etc/splash/livecd-2005.0/images/verbose-8* /etc/make.conf.example /etc/make.globals /etc/resolv.conf
stage4/rm:
+
+# Setting the option overrides the location of the pkgcache
+pkgcache_path:
+
+# Setting the option overrides the location of the kerncache
+kerncache_path:
+
diff --git a/examples/tinderbox_template.spec b/examples/tinderbox_template.spec
index db09899e..d26d880c 100644
--- a/examples/tinderbox_template.spec
+++ b/examples/tinderbox_template.spec
@@ -78,3 +78,10 @@ tinderbox/use:
# exampleL
# tinderbox/packages: dante tsocks sys-apps/eject minicom links acpid apmd parted whois tcpdump cvs zip unzip netcat partimage app-admin/sudo app-cdr/cdrtools gnome emacs dev-lang/ruby enlightenment kde mozilla-firefox mozilla-thunderbird xfce4 openbox fluxbox sylpheed openoffice-bin gimp xemacs xmms abiword gaim xchat pan tetex xcdroast k3b samba nmap gradm ettercap ethereal mplayer
tinderbox/packages:
+
+# Setting the option overrides the location of the pkgcache
+pkgcache_path:
+
+# Setting the option overrides the location of the kerncache
+kerncache_path:
+