summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/yumbootstrap/yumbootstrap-0.0.3_p20150509.ebuild')
-rw-r--r--dev-util/yumbootstrap/yumbootstrap-0.0.3_p20150509.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-util/yumbootstrap/yumbootstrap-0.0.3_p20150509.ebuild b/dev-util/yumbootstrap/yumbootstrap-0.0.3_p20150509.ebuild
deleted file mode 100644
index d480d66..0000000
--- a/dev-util/yumbootstrap/yumbootstrap-0.0.3_p20150509.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 )
-# PYTHON_REQ_USE=berkdb
-# https://bugs.gentoo.org/show_bug.cgi?id=519584
-inherit distutils-r1
-
-MY_PV=ca14281727d6e5476f6601541a1974e65c3a1a33
-DESCRIPTION="chroot installer for derivatives of Red Hat Enterprise Linux"
-HOMEPAGE="https://github.com/dozzie/yumbootstrap"
-SRC_URI="https://github.com/dozzie/yumbootstrap/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3" # or later?
-SLOT="0"
-KEYWORDS="" # ~amd64 ~x86, lazy mask
-IUSE=""
-
-RDEPEND="
- app-arch/rpm[caps,lua,python]
- sys-apps/yum
- dev-python/bsddb3"
-
-S="${WORKDIR}"/${PN}-${MY_PV}
-
-python_prepare_all() {
- sed 's,^import bsddb$,import bsddb3 as bsddb,' -i lib/yumbootstrap/bdb.py || die
-}
-
-python_install_all() {
- DOCS=( KNOWN_ISSUES.md SUITES.md )
- EXAMPLES=( examples )
- distutils-r1_python_install_all
-
- emake \
- PREFIX=/usr \
- SYSCONFDIR=/etc \
- DESTDIR="${D}" \
- install-notmodule
-}